Project

General

Profile

Actions

Bug #11609

closed

CLI interface configuration without IPv6 leaves RA enabled

Added by George Doe 5 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interfaces
Target version:
Start date:
03/03/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
21.05
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:
All

Description

This occurred on a completely new install, version 2.5.0-RELEASE.

Specs:
Mainboard: ASUS ROG MAXIMUS IX FORMULA
CPU: Intel Core i7-7700k 4.20GHz
RAM: 8GB DDR4
Interfaces were the mainboard gigabit Ethernet port (used as WAN) and an intel 82571EB/82571GB network card with 2 ports (one LAN, one unused).
The system was installed via USB stick.

I also replicated the issue in a virtual machine with 2 virtual interfaces. The VMs were installed via DVD image.

I initially set up my interfaces from the shell.

One of the interfaces is configured to be WAN and receive its address via DHCP

I configured a second interface to be the LAN. I configured it to have a static IPv4 address. I configured it it to have no IPv6 address. I configured it to have the DHCPv4 server active on the interface.

I left a third interface entirely unconfigured.

I then went to the web GUI and continued configuration on there.

I clicked through the Setup wizard, adjusting some configuration like timezone but leaving the interface configuration as is. (It retained the values i already set from the command line.)

I then went into the settings of my LAN interface to rename it from "LAN" to "MGMT"

When saving that change, i received an error message that the interface configuration can not be saved. The exact message:
"The following input errors were detected: * The Router Advertisement Server is active on this interface and it can be used only with a static IPv6 configuration. Please Disable the Router Advertisement Server service on this interface first, then change the interface configuration."
Not that i had no IPv6 address at any point.

As instructed i then went to the configuration page "Services" > "DHCPv6 Server & RA". I could not turn off router Advertisement. I was met with the error message:
"The DHCPv6 Server can only be enabled on interfaces configured with a static IPv6 address. This system has none."

This is obviously some sort of dependency loop and should be an unachievable configuration state. I never configured any IPv6 address, thus RA shouldn't have been enabled.

Workaround: I resolved the issue by assigning an IPv6 address to the interface. Then opening the "DHCPv6 Server & RA" settings and disabling router advertisement. Then removing the IPv6 address from the interface again.

Nature of the bug:
Despite assigning no IPv6 at all in the CLI configuration, and only activating the DHCPv4 server, RA was activated on the interface. I suspect this is an issue caused by the CLI configuration tool.

Actions #2

Updated by Jim Pingle 5 months ago

  • Status changed from New to Pull Request Review
  • Target version set to CE-Next
Actions #3

Updated by Renato Botelho 4 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov
  • Target version changed from CE-Next to 2.6.0

PR has been merged. Thanks!

Actions #4

Updated by Viktor Gurov 4 months ago

  • % Done changed from 0 to 100
Actions #5

Updated by Jim Pingle 3 months ago

  • Plus Target Version set to 21.05
Actions #6

Updated by Jim Pingle 3 months ago

Already in 21.05 branch.

Actions #7

Updated by Jim Pingle 3 months ago

  • Subject changed from CLI configuration without IPv6 leaves RA enabled. to CLI configuration without IPv6 leaves RA enabled

Updating subject for release notes.

Actions #8

Updated by Jim Pingle 2 months ago

  • Target version changed from 2.6.0 to 2.5.2
Actions #9

Updated by Jim Pingle 2 months ago

  • Subject changed from CLI configuration without IPv6 leaves RA enabled to CLI interface configuration without IPv6 leaves RA enabled
  • Category changed from Console Menu to Interfaces
Actions #10

Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF