Project

General

Profile

Actions

Bug #11923

closed

Input validation not working for 1:1 NAT entries using an alias as a destination

Added by Massimiliano Cianelli 4 months ago. Updated 3 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Rules / NAT
Target version:
Start date:
05/14/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default
Affected Version:
2.5.1
Affected Architecture:
All

Description

We have some NAT 1:1 configured with the "Destination" field with alias.
Today we discovered that we could not either add or modify any NAT with a destination alias, the answer will be:
The following input errors were detected:

The destination address is not from the specified address family.

The NAT I'm tryin to edit contain the following parameters:
Interface: LAN
Address Family: IPv4
External subnet IP: Single Host - 10.xx.224.0
Internal IP: Network - 10.xx.0.0/24
Destination: Single host or alias - Our_Object_Alias

The alias "Our_Object_Aliases" contain:
10.xx.128.32/29
10.xx.128.40/29

With pfSense version 2.4.5-p1 work without problem, with pfSense 2.5.0 and 2.5.1 we receive the error.


Files

Capture2.PNG (34.8 KB) Capture2.PNG Errors Evan Hellman, 09/22/2021 10:22 PM
Capture1.PNG (147 KB) Capture1.PNG Configuration with two IP Aliases Evan Hellman, 09/22/2021 10:22 PM
Actions #1

Updated by Viktor Gurov 4 months ago

  • Category changed from NAT Reflection to Rules / NAT
  • Status changed from New to Duplicate

Duplicate of #11751

Actions #2

Updated by Viktor Gurov 4 months ago

  • Status changed from Duplicate to New

I can reproduce it on 2.5.1 and 2.6.0.a.20210514.0100

Actions #4

Updated by Jim Pingle 4 months ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.6.0
  • Plus Target Version set to 21.09
Actions #5

Updated by Viktor Gurov 4 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #6

Updated by Alhusein Zawi 4 months ago

  • Status changed from Feedback to Resolved

I was able to add and modify 1:1 NAT with a destination alias without errors.

Fixed

2.6.0.a.20210522.0100

Actions #7

Updated by Jim Pingle 4 months ago

  • Target version changed from 2.6.0 to 2.5.2
Actions #8

Updated by Renato Botelho 3 months ago

  • Assignee set to Viktor Gurov
Actions #9

Updated by Jim Pingle about 1 month ago

  • Subject changed from NAT 1:1 fail to validate aliases to Input validation not working for 1:1 NAT entries using an alias as a destination

Updating subject for release notes.

Actions #10

Updated by Evan Hellman 3 days ago

Confirmed that bug is still present in 2.5.2. Running most recent version and I cannot create 1:1 NAT mappings with aliases. This appears to still affect only 1:1 NAT configurations but now affects the internal and external IP fields.

Actions

Also available in: Atom PDF