Project

General

Profile

Actions

Bug #11939

closed

Editing widgets on Dashboard causes a PHP Warning

Added by T Toft 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Dashboard
Target version:
Start date:
05/20/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
21.05
Release Notes:
Default
Affected Version:
2.6.x
Affected Architecture:

Description

Editing widgets on the Dashbord page causes "PHP Warning: Invalid argument supplied" errors.

To reproduce:
- Go to Dashboard
- Click the edit icon on for example the "System Information" widget
- Add something new like "Temperature" (or remove something)
- Click Save
- A "pfSense has detected a crash report or programming bug" warning appears

Version tested: 2.6.0.a.20210517.0100

--- CRASH REPORT -----------------

Crash report begins. Anonymous machine information:

amd64
12.2-STABLE
FreeBSD 12.2-STABLE devel-12-n226624-e22beee72a6a pfSense

Crash report details:

PHP Errors:
[20-May-2021 14:50:03 Europe/Copenhagen] PHP Warning: Invalid argument supplied for foreach() in /usr/local/www/includes/functions.inc.php on line 276
[20-May-2021 14:50:03 Europe/Copenhagen] PHP Warning: Invalid argument supplied for foreach() in /usr/local/www/includes/functions.inc.php on line 276

No FreeBSD crash data found.

Actions #1

Updated by T Toft 5 months ago

Note that it does work 100 % even though it throws a warning.

Actions #2

Updated by Jim Pingle 5 months ago

  • Project changed from pfSense Packages to pfSense
  • Subject changed from Editing widgets on Dashboard causes a PHP Warning in 2.6.x to Editing widgets on Dashboard causes a PHP Warning
  • Category changed from Apache / mod_security to Dashboard
  • Assignee set to Jim Pingle
  • Priority changed from Very Low to High
  • Target version set to 2.6.0
  • Plus Target Version set to 21.05
  • Release Notes set to Default

It may still function but that is rather ugly.

Actions #3

Updated by Jim Pingle 5 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Jim Pingle 5 months ago

  • Status changed from Feedback to Waiting on Merge

Tested on 2.6.0 and 21.05, was able to reproduce the error before but not with the fix applied. Fix is in master and plus-master currently, needs approval to get into 21.05 since that's under a freeze currently.

It does appear to not break functionality but still is good to fix. Can be bumped to the next version if need be.

Actions #5

Updated by Jim Pingle 5 months ago

  • Status changed from Waiting on Merge to Feedback

This was picked back yesterday.

Actions #6

Updated by Max Leighton 5 months ago

  • Status changed from Feedback to Resolved

Tested on

2.6.0-DEVELOPMENT (amd64)
built on Fri May 21 01:05:01 EDT 2021
FreeBSD 12.2-STABLE

Editing widgets doesn't generate PHP errors any more. I will close out the ticket.

Actions #7

Updated by Jim Pingle 5 months ago

  • Target version changed from 2.6.0 to 2.5.2
Actions

Also available in: Atom PDF