Project

General

Profile

Actions

Regression #12028

closed

SNMP daemon issues with pf nvlist changes

Added by Jim Pingle 4 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Category:
SNMP
Target version:
Start date:
06/11/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:

Description

On 2.5.2.r.20210611.0300 and 2.6.0.a.20210611.0100, the built-in SNMP (bsnmp) logs the following at startup:

Jun 11 12:25:03 rose snmpd[57108]: lm_load: open /usr/lib/libpfctl.so.5: Undefined symbol "nvlist_create" 
Jun 11 12:25:03 rose snmpd[57108]: init dep failed: 13 1.3.6.1.4.1.12325.1.1.1.6 2.112.102
Jun 11 12:25:03 rose snmpd[57108]: error in config file

It still functions for other OIDs and in general.

Actions #1

Updated by Jim Pingle 4 months ago

  • Assignee set to Kristof Provost
Actions #2

Updated by Kristof Provost 3 months ago

  • Status changed from New to Feedback

Look to be fixed by Luiz's a8c3d8e344a7d7e015b78fa4935fcdbd4aec97df.

We were missing the libnv dependency in the libpfctl makefile because we'd included an earlier, broken, version of my patch.

Actions #3

Updated by Renato Botelho 3 months ago

  • Status changed from Feedback to Resolved

libpfctl is now linked to libnv

[2.5.2-RC][admin@pfSense.home.arpa]/root: ldd /usr/lib/libpfctl.so.5
/usr/lib/libpfctl.so.5:
    libnv.so.0 => /lib/libnv.so.0 (0x80065d000)
    libc.so.7 => /lib/libc.so.7 (0x80024e000)
Actions #4

Updated by Jim Pingle 3 months ago

I no longer get the original error on startup, and I am able to see data from the PF MIB:

$ snmpwalk -M /usr/local/share/snmp/mibs:/usr/share/snmp/mibs -On -v 2c -c public <blah> BEGEMOT-PF-MIB::pfStatus
.1.3.6.1.4.1.12325.1.200.1.1.1.0 = INTEGER: true(1)
.1.3.6.1.4.1.12325.1.200.1.1.2.0 = Timeticks: (127300) 0:21:13.00 1/100th of a Second
.1.3.6.1.4.1.12325.1.200.1.1.3.0 = INTEGER: urgent(1)
.1.3.6.1.4.1.12325.1.200.1.1.4.0 = STRING: "0xaf031bf4" 
Actions #5

Updated by Jim Pingle 3 months ago

  • Subject changed from SNMP daemon error on latest snapshot to SNMP daemon issues with pf nvlist changes
  • Status changed from Resolved to New
  • Target version changed from 2.5.2 to 2.6.0
  • Release Notes changed from Default to Force Exclusion

The changes here have been backed out of 2.5.2 so we'll need to check/test 2.6.0 once it has been synchronized with upstream.

Excluding from release notes since it's not going to be a problem in any release (introduced in snapshots and fixed there as well)

Actions #6

Updated by Jim Pingle about 1 month ago

  • Status changed from New to Resolved

This is fine on current snapshots.

No errors in SNMP logs. SNMP queries return expected results. libpfctl.so.5 is linked against libnv.so.0 as expected.

Actions

Also available in: Atom PDF