Project

General

Profile

Actions

Regression #12215

closed

OpenVPN does not resync when running on a gateway group

Added by James Webb over 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Hi all,

It seems that quite a bit of the codebase has changed in the relevant files since the fix I implemented in #9595. This change has caused a regression and as such the same issue that was originally defined in #9595 is now reoccuring. This is likely causing issues in quite a few deployments.

Best wishes,
James.


Related issues

Related to Bug #12613: DNS Resolver does not restart during link up/down events on a static IP address interfaceResolvedViktor Gurov

Actions
Related to Regression #11570: Gateway monitoring services is not always restarted on interface events, which may prevent a WAN from recovering back to an online stateClosed

Actions
Actions #1

Updated by Jim Pingle over 2 years ago

  • Tracker changed from Bug to Regression
Actions #2

Updated by Viktor Gurov over 2 years ago

  • Status changed from New to Feedback

Unable to reproduce on 2.6.0.a.20210805.0500 -
OpenVPN with gwgroup successfully resync on gateway failure/restore

here is your code:
https://github.com/pfsense/pfsense/blob/master/src/etc/inc/openvpn.inc#L1720-L1742

Actions #3

Updated by Viktor Gurov over 2 years ago

seems related #11570 and #12613

Actions #4

Updated by Viktor Gurov over 2 years ago

  • Related to Bug #12613: DNS Resolver does not restart during link up/down events on a static IP address interface added
Actions #5

Updated by Viktor Gurov over 2 years ago

  • Related to Regression #11570: Gateway monitoring services is not always restarted on interface events, which may prevent a WAN from recovering back to an online state added
Actions #6

Updated by Oskar Stroka over 1 year ago

I'm also affected by this.
OpenVPN Client on DSL (PPPoE) and another OpenVPN Client on LTE (DHCP), both on Tier 1 in a Gateway Group.
LTE failed today for a few minutes, after it came back up OpenVPN reported to be connected, but there was no traffic passing this Interface (except for ICMP / dpinger).
Restarting the OpenVPN Service fixed that.

Actions #7

Updated by Jordan G 11 months ago

seeing this with 23.05, OpenVPN using a gateway group as the interface won't failover unless dpinger is restarted, but it appears to fail-back when the connection is restored.

Actions #8

Updated by Jordan G 10 months ago

23.05.1 has OpenVPN clients using the configured gateway group as the correct interface(s) and appears to failover and back upon latency/packet-loss threshold being surpassed

Actions #9

Updated by Jim Pingle 9 months ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF