Project

General

Profile

Actions

Regression #12396

closed

PHP Warning: Use of undefined constant ip - /etc/inc/services.inc on line 2465

Added by JP Versteeg 8 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
PHP Interpreter
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:

Description

Hi Team,
Could you please confirm. Many thanks.

Issue identified following the first reboot, after fully completing installation of 21.09RC upgrading from 21.02.

Error produced in GUI
PHP Warning:
Use of undefined constant ip - assumed 'ip' (this will throw an Error in a future version of PHP) in /etc/inc/services.inc on line 2465

A comparison of the local file with github showed the same line in both.
line 2465 /etc/inc/services.inc
line 2465 https://github.com/pfsense/pfsense/blob/master/src/etc/inc/services.inc

  1. Proposed change
  1. /etc/inc/services.inc line 2461-2469

/* Setup forwarded domains */
if (isset($config['dnsmasq']['domainoverrides']) && is_array($config['dnsmasq']['domainoverrides'])) {
foreach ($config['dnsmasq']['domainoverrides'] as $override) {
if ($override['ip'] == "!") {
- $override[ip] = "";
+ $override['ip'] = "";
}
$args .= ' --server=/' . $override['domain'] . '/' . $override['ip'];
}
}

Actions #1

Updated by Jim Pingle 8 months ago

  • Status changed from New to Pull Request Review
  • Assignee set to Christian McDonald
  • Target version set to CE-Next
  • Plus Target Version set to 22.01

Odd that it would just start giving an error now since that line, as obviously wrong as it is, hasn't changed in 7 years. It's in code for the DNS Forwarder, which isn't used by default.

Most likely the latest version of PHP in use now is being more strict about such things.

Actions #2

Updated by Christian McDonald 8 months ago

  • Status changed from Pull Request Review to Feedback
Actions #3

Updated by Christian McDonald 8 months ago

Jim Pingle wrote in #note-1:

Most likely the latest version of PHP in use now is being more strict about such things.

I suspect the same.

Actions #4

Updated by JP Versteeg 8 months ago

Many thanks. Do you want me to close this?

Actions #5

Updated by Jim Pingle 7 months ago

  • Target version changed from CE-Next to 2.6.0
Actions #6

Updated by Jim Pingle 7 months ago

  • Tracker changed from Bug to Regression
  • Release Notes changed from Default to Force Exclusion

Since this was only a regression in snapshots, no need to include it in release notes.

Actions #7

Updated by Jim Pingle 4 months ago

  • Status changed from Feedback to Resolved

Correct code is present in the repo.

Actions

Also available in: Atom PDF