Project

General

Profile

Actions

Bug #12900

closed

Clicking Save & Force Update on a Dynamic DNS entry results in a GUI timeout

Added by Max Leighton 4 months ago. Updated about 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
22.05
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

When creating a new Cloudflare Dynamic DNS entry or saving and forcing an update nginx will timeout with 504. The update will work, and the DDNS entry functions correctly. I don't know if this happens with other DDNS providers as I have only tested with Cloudflare. The issue only seems to happen on success, the GUI reloads without issues on failure. I see this whether using Zone ID or email/global API key for auth.


Related issues

Is duplicate of Bug #12870: Clicking Save & Force Update on a Dynamic DNS entry results in a GUI timeoutResolvedJim Pingle

Actions
Actions #1

Updated by Jim Pingle 4 months ago

  • Subject changed from Cloudflare DDNS Save & Force Update results in nginx timeout to Clicking Save & Force Update on a Dynamic DNS entry results in a GUI timeout
  • Target version set to 2.7.0
  • Plus Target Version set to 22.05

It's not just CloudFlare, I'm seeing this on Namecheap as well.

Actions #2

Updated by Marcos Mendoza 3 months ago

Tested on 22.05.a.20220402.0600; got a 504 timeout with Cloudflare, but not with HE.net Tunnelbroker.

Actions #3

Updated by Ryan Coleman 2 months ago

Confirmed this is happening with 22.01 as well. Unclear if it is updating the record as well, but receiving the 504 error.

Actions #4

Updated by Marcos Mendoza about 2 months ago

  • Is duplicate of Bug #12870: Clicking Save & Force Update on a Dynamic DNS entry results in a GUI timeout added
Actions #5

Updated by Marcos Mendoza about 2 months ago

  • Status changed from New to Duplicate
Actions

Also available in: Atom PDF