Project

General

Profile

Feature #13

wireless page to have option to select transmit and receive antennas

Added by Bipin Chandra about 10 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/09/2009
Due date:
% Done:

100%

Estimated time:

Description

in the wireless section this has been talked about and was said it would be added in future releases but nothing so far, not every1 has 2 antennas for receive and broadcast so an option to be able to select the transmit and receive antennas should be there configuring it properly can avoid wek wireless signals coz i have one antenna and connected to port 0 on the wireless card but am unable to select the same for both transmit and receive

Associated revisions

Revision 56626335 (diff)
Added by Erik Fonnesbeck about 9 years ago

Add backend code for antenna settings. Ticket #13

Revision 537bf7b3 (diff)
Added by Erik Fonnesbeck about 9 years ago

Add gui code for antenna settings. Ticket #13

History

#1 Updated by Chris Buechler about 10 years ago

  • Assignee deleted (Chris Buechler)

#2 Updated by Chris Buechler about 10 years ago

  • Target version deleted (1.2.3)

#3 Updated by Erik Fonnesbeck over 9 years ago

For now, in 2.0 I think it could be done by adding settings in System: Advanced: System Tunables to adjust these options. The settings are dev.ath.0.txantenna , dev.ath.0.rxantenna , and dev.ath.0.diversity (with higher numbers for additional cards).

The numbers this page specifies to use for the settings should probably be applicable on the FreeBSD ath driver, too: http://madwifi-project.org/wiki/UserDocs/AntennaDiversity#Controllingdiversity

#4 Updated by Bipin Chandra over 9 years ago

the madwifi page says:
0-auto
1-antenna 1
2-antenna 2

but in the pfsense wireless forum others listed the below
0-antenna 1
1-antenna 2
2-auto

ref:
[[http://forum.pfsense.org/index.php/topic,1007.0.html]]
[[http://forum.pfsense.org/index.php/topic,1149.msg6765.html#msg6765]]

#5 Updated by Erik Fonnesbeck over 9 years ago

I'm not sure whether the information lsf gave was correct. Based on the defaults I've seen on various cards I have, the madwifi page would seem to be correct for FreeBSD, too. Otherwise none of my cards are using the auto setting by default for both txantenna and rxantenna, which is opposite of what I would expect, especially for the Atheros 5416 802.11n card I've tested. I will test it, though.

#6 Updated by Bipin Chandra over 9 years ago

im also using the atheros based Compex WLM54SAG23 and pfsense used to default it to 2 for tx and rx and i used to notice high in/out errors but after ur suggestion i put those values under tunables and set it to 1 based on madwifi page and now in/out errors r just under 100 for almost more than a day.

#7 Updated by Bipin Chandra over 9 years ago

what i noticed with the latest snapshot was that dev.ath.0.txantenna , dev.ath.0.rxantenna , and dev.ath.0.diversity values set under system tunables dont apply at all bcoz when u try out the following commands

sysctl dev.ath.0.txantenna
sysctl dev.ath.0.rxantenna
sysctl dev.ath.0.diversity

all return the default value which being 0 for first two and 0 for the third which also means 0 is auto, 1 is antenna 1 and 2 is antenna 2 and diversity is off by default

#8 Updated by Bipin Chandra over 9 years ago

further investigation shows that the default is

tx - 0
rx - 1
div - 1

which means 0 is antenna 0 and 1 is antenna 1 and 2 is auto, exactly what was mentioned in the forum.

regarding the values under system tunables not applying, actually it applies on reboot but if there is a stuck beacon on the wifi card and then resets then those values r not reapplied.

#9 Updated by Erik Fonnesbeck over 9 years ago

Other than the sysctl values, what does athstats say about antennas on your card?

By the way, I've found on a system with an Atheros 5212-based card running 1.2.3 that setting txantenna to 0 automatically enables diversity and txantenna to 1 causes it to disable diversity. I'm not sure whether the same happens on 2.0. The system I used to test it on 2.0 has a different card, though, so it may not behave the same. (Atheros 5416)

#10 Updated by Bipin Chandra over 9 years ago

$ athstats
3605891 data frames received
133799 data frames transmit
2900 short on-chip tx retries
47625 long on-chip tx retries
8642 tx failed 'cuz too many retries
1M current transmit rate
52523 tx frames with no ack marked
66110 tx frames with short preamble
42664 tx frames with 11g protection
335311 rx failed 'cuz of bad CRC
15 rx failed 'cuz frame too short
96395 rx failed 'cuz of PHY err
90 OFDM restart
96305 CCK restart
510637 beacons transmitted
2272 periodic calibrations
-0/+0 TDMA slot adjust (usecs, smoothed)
8 rssi of last ack
9 avg recv rssi
-96 rx noise floor
15166 tx frames through raw api
303 cabq frames transmitted
122 cabq xmit overflowed beacon interval
169 switched default/rx antenna
Antenna profile:
[1] tx 121665 rx 3599260
[2] tx 3490 rx 6631

#11 Updated by Chris Buechler over 9 years ago

from one of mine (Atheros 5413)

  1. athstats
    297648 data frames received
    388321 data frames transmit
    4570 tx frames with an alternate rate
    174741 long on-chip tx retries
    10822 tx failed 'cuz too many retries
    24M current transmit rate
    86592 tx frames with no ack marked
    234923 tx frames with short preamble
    8519 rx failed 'cuz of bad CRC
    17 rx failed 'cuz of PHY err
    9 OFDM restart
    8 CCK restart
    386916 beacons transmitted
    112255 periodic calibrations
    -0/+0 TDMA slot adjust (usecs, smoothed)
    43 rssi of last ack
    43 avg recv rssi
    -96 rx noise floor
    66806 tx frames through raw api
    4303 cabq frames transmitted
    2858 cabq xmit overflowed beacon interval
    8233 switched default/rx antenna
    Antenna profile:
    [1] tx 234208 rx 188467
    [2] tx 140432 rx 109181

#12 Updated by Bipin Chandra over 9 years ago

mine is a atheros 5414 chipset but BSD reports it as 5413 due to drivers

#13 Updated by Erik Fonnesbeck over 9 years ago

I'm fairly sure 0 does mean auto on those sysctl settings, so that's what should be labeled auto if this setting is exposed through the web GUI.

From the athstats output Chris has posted, based on previous information given above I expect that currently txantenna is 0, rxantenna is 0, and diversity is 1 on his.

Should have enough information now to implement this.

#14 Updated by Bipin Chandra over 9 years ago

all that i can say is when tx and rx antenna r set to 0 and diversity off then i get much better signal strength in further away rooms in my home compared to setting it both to 1

#15 Updated by Erik Fonnesbeck about 9 years ago

  • Status changed from New to Feedback
  • Target version set to 2.0
  • % Done changed from 0 to 100

implemented

#16 Updated by Bipin Chandra about 9 years ago

thanks for the effort, ill test it out once i get the pppoe reconnect issue sorted out due to which im stuck on the 30th august snap.

#17 Updated by Bipin Chandra almost 9 years ago

im still not sure 0,1,2 values r labeled properly coz when i set all 3 to 0, i get the best transmittion and reception and antenna is only connected to the main plug.

#18 Updated by Erik Fonnesbeck almost 9 years ago

It may be different depending on the card, but it has been as labeled on two different single-antenna systems with different cards. In my single-antenna configurations I have diversity off, one is using antenna 1 for TX/RX, and the other system is using antenna 2 for TX/RX. In both cases I got the best or worst signal between number 1 or 2 and alternating between the two or somewhere in the middle when on auto. I confirmed this on one of my other systems by using a program that constantly monitors and graphs the signal levels, updating every second. The one I used in my case was the one called inSSIDer.

If you check it out with a program like that to test the signals from the single-antenna setup, you should see two different settings that each give relatively stable signal, one higher and one lower, and a setting that approximately alternates between those two signal levels. Probably not going to change the labels even if your results come out differently, though. Might add a note in that case, possibly.

#19 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

#20 Updated by Bipin Chandra over 8 years ago

on latest snap, 9th dec, i have set diversity to 1 as i have connected antennas on both connectors and set the tx and rx both to auto so after a reboot sysctl dev.ath should show diversity to 1 and the tx and rx to 0 but it doesnt, diversity remains 0 and tx to 0 and rx to 2 for some reason so i guess those antenna settings r not applied on bootup.

Also available in: Atom PDF