Project

General

Profile

Actions

Bug #13127

closed

DHCP lease list displays wrong interface name in the "Leases in Use" summary if DHCP settings for a disabled interface remain in the configuration

Added by → luckman212 about 2 months ago. Updated 26 days ago.

Status:
Resolved
Priority:
Normal
Category:
DHCP (IPv4)
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
22.05
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

22.01-RELEASE

repro:

  • Netgate 4100
  • enable DHCP server on LAN1
  • later, create BRIDGE interface named LAN_BRIDGE (members: LAN1-4)
  • edit LAN1 interface -> disable
  • enable DHCP server on LAN_BRIDGE
  • go to Status -> DHCP Leases
  • note the Ifname at the bottom will say "LAN1"

manual fix:

  • go into config.xml and delete the unused interface from <dhcpd> e.g. <lan></lan>
  • reload the page, correct ifname will be displayed

I'm sure this is a simple fix, haven't looked too deeply yet but I will make a PR if I can


Files

clipboard-202205041234-72uen.png (28.5 KB) clipboard-202205041234-72uen.png → luckman212, 05/04/2022 11:34 AM
clipboard-202205041235-5xs55.png (29.8 KB) clipboard-202205041235-5xs55.png → luckman212, 05/04/2022 11:35 AM
Actions #1

Updated by → luckman212 about 2 months ago

Found the issue, fix coming now

Actions #3

Updated by Jim Pingle about 2 months ago

  • Project changed from pfSense Plus to pfSense
  • Subject changed from status_dhcp_leases.php displays wrong interface name if a phantom interface remains in the config.xml under dhcpd to DHCP lease list displays wrong interface name in the "Leases in Use" summary if DHCP settings for a disabled interface remain in the configuration
  • Category changed from DHCP Server (IPv4) to DHCP (IPv4)
  • Target version set to 2.7.0
  • Affected Plus Version deleted (22.01)
  • Plus Target Version set to 22.05
Actions #4

Updated by Jim Pingle about 2 months ago

  • Status changed from New to Pull Request Review
Actions #5

Updated by Viktor Gurov about 1 month ago

  • Status changed from Pull Request Review to Feedback
Actions #6

Updated by Jim Pingle 29 days ago

  • Assignee set to → luckman212
Actions #7

Updated by Reid Linnemann 28 days ago

  • Status changed from Feedback to Resolved
Actions #8

Updated by Reid Linnemann 28 days ago

  • Status changed from Resolved to Assigned
  • Assignee changed from → luckman212 to Reid Linnemann
  • Target version changed from 2.7.0 to CE-Next
  • Plus Target Version changed from 22.05 to Plus-Next

When I test this, the interface name becomes an empty string.

Actions #9

Updated by → luckman212 28 days ago

Hmm weird, I didn't experience that on my systems. What's the name of your interface?

Actions #10

Updated by Jim Pingle 28 days ago

  • Target version changed from CE-Next to 2.7.0
  • Plus Target Version changed from Plus-Next to 22.09
Actions #11

Updated by → luckman212 26 days ago

Reid Linnemann : Can you send a screenshot of that rendered page with the blank ifname? I looked again at the code and it seems ok, unless dhcpif is somehow unset or maybe contains weird characters in your config.xml.

Can you try the test patch at https://github.com/luckman212/pfsense/commit/7ed258f91be8b49f6a90d50715cb31bc5e3e099c and see if that changes anything?

Actions #12

Updated by Reid Linnemann 26 days ago

It's just blank, the table data for the cell is empty. I'll get a chance to have a further look at it in the next few days. It's possible other changes in master are involved, or how I tested the change was just different enough to reveal another edge case.

Actions #13

Updated by Reid Linnemann 26 days ago

  • Status changed from Assigned to Resolved
  • Plus Target Version changed from 22.09 to 22.05

I've tested again on a fresh image and I cannot get it to repeat the blank interface name, the interface name changes as expected to the name of the bridge. I say the issue is resolved and I'll open a new issue if I can cause it to happen again.

Actions

Also available in: Atom PDF