Project

General

Profile

Actions

Regression #13147

closed

Captive Portal: Idle timeout does not see activity

Added by Steve Wheeler about 2 months ago. Updated 29 days ago.

Status:
Resolved
Priority:
Normal
Category:
Captive Portal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.05
Release Notes:
Force Exclusion
Affected Version:
2.7.x
Affected Architecture:
All

Description

The idle timeout value is applied regardless of activity from the connected user. Functions as a hard timeout.

Here set for 5mins:

May 10 22:11:00     logportalauth     387     Zone: test_zone - ACCEPT: unauthenticated, 3a:d2:8d:84:6e:56, 192.168.20.10
May 10 22:16:08     logportalauth     45924     Zone: test_zone - IDLE TIMEOUT: unauthenticated, 3a:d2:8d:84:6e:56, 192.168.20.10
May 10 22:17:19     logportalauth     387     Zone: test_zone - ACCEPT: unauthenticated, 3a:d2:8d:84:6e:56, 192.168.20.10
May 10 22:23:09     logportalauth     5291     Zone: test_zone - IDLE TIMEOUT: unauthenticated, 3a:d2:8d:84:6e:56, 192.168.20.10
May 10 22:23:28     logportalauth     387     Zone: test_zone - ACCEPT: unauthenticated, 3a:d2:8d:84:6e:56, 192.168.20.10
May 10 22:29:10     logportalauth     14389     Zone: test_zone - IDLE TIMEOUT: unauthenticated, 3a:d2:8d:84:6e:56, 192.168.20.10 

Tested: 22.05.a.20220510.1205


Related issues

Related to Todo #13100: Transition Captive Portal from IPFW to PFResolvedViktor Gurov

Actions
Actions #1

Updated by Viktor Gurov about 2 months ago

  • Related to Todo #13100: Transition Captive Portal from IPFW to PF added
Actions #2

Updated by Viktor Gurov about 2 months ago

  • Assignee set to Viktor Gurov
  • Release Notes changed from Default to Force Exclusion
Actions #4

Updated by Viktor Gurov about 2 months ago

  • Assignee changed from Viktor Gurov to Reid Linnemann

pfSense_pf_cp_get_eth_last_active("{$anchor}/{$ip}_32") returns empty array

Actions #5

Updated by Reid Linnemann about 2 months ago

It returns an empty array because the function never actually called pf_ctl_get_eth_rules() to get the rules before iterating over them. Fix is inbound.

Actions #6

Updated by Reid Linnemann about 2 months ago

Additionally, the function captiveportal_get_last_activity() did not declare $config as a global, so the zone id was always an empty string. A fix for this is incoming as well.

Actions #7

Updated by Anonymous about 2 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #8

Updated by Reid Linnemann 29 days ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF