Project

General

Profile

Actions

Regression #13167

closed

DigitalOcean Dynamic DNS update fails with a "bad request" error

Added by Chris C almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Dynamic DNS updates using the DigitalOcean plugin are failing, it looks like phpDynDNS isn't expecting a hyphen in the x-request-id field:

May 15 19:31:00 php-fpm 62993 /services_dyndns_edit.php: Configuration Change: admin@REDACTED (Local Database): Dynamic DNS client configured.
May 15 19:31:00 check_reload_status 398 Syncing firewall
May 15 19:31:00 php-fpm 62993 /services_dyndns_edit.php: Dynamic DNS: updatedns() starting
May 15 19:31:00 php-fpm 62993 /services_dyndns_edit.php: Dynamic DNS digitalocean (hostname): REDACTED extracted from local system.
May 15 19:31:00 php-fpm 62993 /services_dyndns_edit.php: Dynamic DNS (hostname): running get_failover_interface for wan. found igc0
May 15 19:31:00 php-fpm 62993 /services_dyndns_edit.php: Dynamic DNS digitalocean (hostname): _update() starting.
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: HTTP/2 400
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: date: Sun, 15 May 2022 19:31:01 GMT
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: content-type: application/json; charset=utf-8
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: content-length: 126
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: ratelimit-limit: 5000
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: ratelimit-remaining: 4998
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: ratelimit-reset: 1652646661
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: x-gateway: Edge-Gateway
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: x-request-id: 0912d1db-6a1b-4237-875d-e03a6ab8162e
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: x-response-from: service
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: cf-cache-status: DYNAMIC
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: set-cookie: __cf_bm=hTLUHGs.34rxL8MEi8urUw105Fc_qX3e88eJjcpU.8-1652643061-0-AZYG6bSsYrJw6QkwPnoF6ayYx5PdN589k0+4+jgxnlDsL+7Pvd3+Ueo6Xrho+XuwMpZiuvSNLm0fKy/hZpKy3QfdGPpGsZlRmrO81if+p; path=/; expires=Sun, 15-May-22 20:01:01 GMT; domain=.digitalocean.com; HttpOnly; Secure; SameSite=None
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: server: cloudflare
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header: cf-ray: 70be4a9dfe65e11a-IAD
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header:
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Header:
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Response Data: {"id":"bad_request","message":"invalid character '-' in numeric literal","request_id":"0912d1db-6a1b-4237-875d-e03a6ab8162e"}
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: Dynamic DNS digitalocean (hostname): _checkStatus() starting.
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: phpDynDNS (hostname): PAYLOAD: {"id":"bad_request","message":"invalid character '-' in numeric literal","request_id":"0912d1db-6a1b-4237-875d-e03a6ab8162e"}
May 15 19:31:01 php-fpm 62993 /services_dyndns_edit.php: phpDynDNS (hostname): (Unknown Response)

Actions #1

Updated by Chris C almost 2 years ago

Saved before I added the affected version: 2.6.0-RELEASE (amd64)

Actions #2

Updated by Pan Teparak almost 2 years ago

any updates on this? I am getting the same error too

Actions #3

Updated by David Grenier almost 2 years ago

+1 Also having this problem

Actions #4

Updated by r a almost 2 years ago

+1 Having this issue since 16th May on two separate boxes CE. Upgraded to 2.6 and still the same. switch to DynDns and it works. There is a forum post for the same.
Its pointing here so Just want to bump this so it gets attention.
https://forum.netgate.com/topic/172202/ddns-with-digitalocean-api-invalid-character-in-numeric-literal-request_id?_=1654624799991

Actions #5

Updated by Danilo Zrenjanin almost 2 years ago

I reproduced the issue on 22.01 and 22.05.r.20220604.1403 with the same logs.

Actions #6

Updated by Emmanuel Rosado almost 2 years ago

+1 Also having this problem : 2.6.0-RELEASE (amd64)

Actions #7

Updated by Mark Lynch over 1 year ago

Same here. Issue has arisen across two domains served on DigitalOcean on 22.05
Having to use Google custom setup for now.

Actions #8

Updated by IT Admin over 1 year ago

Dogpiling on -- have two pfSense+ (Netgate appliances) that have experienced this issue... Both on 22.05-RELEASE

BTW, the patch to `/etc/inc/dyndns.class` listed in https://forum.netgate.com/topic/172202/ddns-with-digitalocean-api-invalid-character-in-numeric-literal-request_id?_=1659824952378 works to fix the issue.

Actions #9

Updated by Jim Pingle over 1 year ago

  • Target version set to 2.7.0
  • Plus Target Version set to 22.11
Actions #10

Updated by Jason Schechner over 1 year ago

Another +1, with a bit more information. I have 3 pfSense 2.6.0 boxes: 2 in an HA pair and 1 standalone. Both sites update dynamic DNS records at Digital Ocean and an OpenDNS. The standalone box appeared to be working fine, but that's only because my external IP rarely changes (hooray for FiOS) and I haven't changed the dynamic DNS there config in months. To test it just now, I added a new entry which caused all DigitalOcean records to start failing. OpenDNS continues to work fine on all three boxes. I'd set up failover about two months ago, which is when the problem started appearing on those machines, but after testing with the standalone, it's clear that the failover setup didn't cause the problem, it just triggered it by trying to update the Digital Ocean entries. I only note that in case others are seeing this problem show up only after making seemingly-unrelated changes.

The patch that IT Admin included on Aug 6th worked like a charm for all of my instances. I was pulling out what's left of my hair trying to figure out if/how failover was causing the update problem, so thank you for posting it!

Actions #11

Updated by Antes Despues over 1 year ago

the issue seems to be resolved. I'm no longer getting this error.

Actions #12

Updated by Danilo Zrenjanin over 1 year ago

  • Status changed from New to Resolved

I can confirm it works as expected.

Tested against:

22.05-RELEASE (arm)
built on Wed Jun 22 18:56:40 UTC 2022
FreeBSD 12.3-STABLE

I am marking this ticket resolved/closed.

Actions #13

Updated by Marcos M over 1 year ago

  • Status changed from Resolved to Closed
Actions #14

Updated by Jim Pingle over 1 year ago

  • Plus Target Version changed from 22.11 to 23.01
Actions #15

Updated by Jim Pingle over 1 year ago

  • Subject changed from phpDynDNS: DigitalOcean ddns update fails (bad request, invalid character '-' in request_id) to DigitalOcean Dynamic DNS update fails with a "bad request" error

Updating subject for release notes.

Actions #16

Updated by Jim Pingle over 1 year ago

  • Tracker changed from Bug to Regression
  • Status changed from Closed to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF