Project

General

Profile

Actions

Bug #13177

closed

pppoe Cannot attach to ng_ether message: Invalid argument.

Added by net blues about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Upgrade
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:
amd64

Description

pppoe fails to start after upgrading to 22.05 beta (from 22.01)
No session is ever established,

see
https://forum.netgate.com/topic/172190/22-05-b-20220513-0600-pppoe-cannot-attach-to-ng_ether-message-invalid-argument?_=1652758049265

May 15 19:50:46 ppp 27472 [wan_link0] Link: reconnection attempt 1 in 2 seconds
May 15 19:50:46 ppp 27472 [wan_link0] LCP: Down event
May 15 19:50:46 ppp 27472 [wan_link0] Link: DOWN event
May 15 19:50:46 ppp 27472 [wan_link0] PPPoE node for link is not initialized
May 15 19:50:46 ppp 27472 [wan_link0] PPPoE: Error creating ng_pppoe node on vtnet0:
May 15 19:50:46 ppp 27472 [vtnet0] Cannot attach to ng_ether message: Invalid argument.
May 15 19:50:46 ppp 27472 [wan_link0] LCP: LayerStart
May 15 19:50:46 ppp 27472 [wan_link0] LCP: state change Initial --> Starting
May 15 19:50:46 ppp 27472 [wan_link0] LCP: Open event
May 15 19:50:46 kernel ng0: changing name to 'pppoe0'
May 15 19:50:46 ppp 27472 [wan_link0] Link: OPEN event
May 15 19:50:46 ppp 27472 [wan] Bundle: Interface ng0 created
May 15 19:50:46 ppp 27472 web: web is not running
May 15 19:50:46 ppp 27472 process 27472 started, version 5.9
May 15 19:50:46 ppp 27472 Multi-link PPP daemon for FreeBSD


Related issues

Related to Regression #12688: pppoe won’t connect after upgrade to 2.7.0.a.20220115.0600ResolvedKristof Provost

Actions
Actions #1

Updated by Viktor Gurov about 1 month ago

  • Project changed from pfSense Plus to pfSense
  • Category changed from PPP Interfaces to PPP Interfaces
  • Assignee set to Kristof Provost
  • Target version changed from 22.05 to 2.7.0
  • Affected Plus Version deleted (22.05)
  • Plus Target Version set to 22.05
  • Affected Version set to 2.7.0

I see the same issue on 3100 appliance, but not on 5100.

seems related to #12688 and https://github.com/pfsense/FreeBSD-src/commit/fdcdd81fb82dfd8778e2c239162a596a756f236f

Actions #2

Updated by Viktor Gurov about 1 month ago

  • Related to Regression #12688: pppoe won’t connect after upgrade to 2.7.0.a.20220115.0600 added
Actions #3

Updated by Viktor Gurov about 1 month ago

  • Category changed from PPP Interfaces to Upgrade

3100 result:

[22.05-BETA][root@xxx]/root: pkg info -x mpd5
mpd5-5.9_6
[22.05-BETA][root@xxx]/root: pkg info -x pfSense-rc
pfSense-rc-22.05.b.20220513.0600
[22.05-BETA][root@xxx]/root: pkg info -x pfSense-base
pfSense-base-22.05.b.20220513.0600

mpd5 has not been updated to 5.9_7

Actions #4

Updated by Jim Pingle about 1 month ago

  • Status changed from New to Rejected
  • Assignee deleted (Kristof Provost)
  • Priority changed from Very High to Normal
  • Target version deleted (2.7.0)
  • Plus Target Version deleted (22.05)

This is not a problem on its own. It's a side effect of mpd not being updated because the upgrade was not fully completed for some reason (e.g. squidGuard interrupted the upgrade process).

Actions

Also available in: Atom PDF