Project

General

Profile

Actions

Regression #12688

closed

pppoe won’t connect after upgrade to 2.7.0.a.20220115.0600

Added by Dee D 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
PPP Interfaces
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
22.05
Release Notes:
Force Exclusion
Affected Version:
2.7.0
Affected Architecture:

Description

I was on a 2.7 build from a few days previous where it was working.


Related issues

Related to Bug #13177: pppoe Cannot attach to ng_ether message: Invalid argument. Rejected

Actions
Is duplicate of Bug #12690: 6RD PPPoE WAN Configuration Broken in 2.7.0-DEVELOPMENTDuplicate

Actions
Actions #2

Updated by Kris Phillips 4 months ago

Can someone having this issue please provide their PPPoE system logs?

Actions #3

Updated by Dee D 4 months ago

Kris Phillips wrote in #note-2:

Can someone having this issue please provide their PPPoE system logs?

Jan 15 07:22:48 ppp 15086 [opt1_link0] Link: reconnection attempt 1281 in 2 seconds
Jan 15 07:22:50 ppp 15086 [opt1_link0] Link: reconnection attempt 1281
Jan 15 07:22:50 ppp 15086 [hn1] Cannot attach to ng_ether message: Invalid argument.
Jan 15 07:22:50 ppp 15086 [opt1_link0] PPPoE: Error creating ng_pppoe node on hn1:
Jan 15 07:22:50 ppp 15086 [opt1_link0] PPPoE node for link is not initialized
Jan 15 07:22:50 ppp 15086 [opt1_link0] Link: DOWN event
Jan 15 07:22:50 ppp 15086 [opt1_link0] LCP: Down event
Jan 15 07:22:50 ppp 15086 [opt1_link0] Link: reconnection attempt 1282 in 3 seconds

Etc

Actions #4

Updated by Viktor Gurov 4 months ago

  • Category changed from Gateways to PPP Interfaces
  • Assignee set to Kristof Provost
Actions #5

Updated by Viktor Gurov 4 months ago

  • Is duplicate of Bug #12690: 6RD PPPoE WAN Configuration Broken in 2.7.0-DEVELOPMENT added
Actions #6

Updated by Jim Pingle 4 months ago

Is this only on 2.7 snapshots and not 2.6-RC?

I have several systems with PPPoE and L2TP WANs in my lab on 2.6 RC and they can connect OK.

Actions #7

Updated by Kristof Provost 4 months ago

That'd make sense, because I deliberately waited to merge https://github.com/pfsense/FreeBSD-src/commit/fdcdd81fb82dfd8778e2c239162a596a756f236f until after the 2.6.0 branch was created. So I'd expect this to only affecgt 2.7.0 and not the upcoming release.

We don't remove ng_ether nodes any more, so dropping patch-verify-ng-ether-attch.diff (which attempts to re-create it) from mpd5 should suffice to fix this issue.

Actions #9

Updated by Jim Pingle 4 months ago

  • Tracker changed from Bug to Regression
  • Status changed from New to Pull Request Review
  • Target version set to 2.7.0
  • Plus Target Version set to 22.05
  • Release Notes changed from Default to Force Exclusion
  • Affected Version set to 2.7.0
Actions #10

Updated by Viktor Gurov 4 months ago

  • Status changed from Pull Request Review to Feedback
Actions #11

Updated by Louis van Breda 4 months ago

Hello, I week ago PPPOE WAN did not work (I did report that in the forum). Today I felt comfortable enough to try the update :)

I can report that the patch works for me.

Actions #12

Updated by Jim Pingle 4 months ago

  • Status changed from Feedback to Resolved

Thanks for following up!

Actions #13

Updated by Viktor Gurov 6 days ago

  • Related to Bug #13177: pppoe Cannot attach to ng_ether message: Invalid argument. added
Actions

Also available in: Atom PDF