Project

General

Profile

Actions

Bug #13600

closed

Saving a DDNS entry can lead to the GUI timing out.

Added by Marcos M 3 months ago. Updated 13 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Dynamic DNS
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

On pfSense-23.01.a.20221026.0600:
  1. Add a DDNS entry with:
    • Service Type: Cloudflare
    • Disable: checked
    • Interface to monitor: gateway group with single gateway
    • Hostname: valid hostname/domain
    • Username: Zone ID
    • Password: Zone API token
  2. Click Save
  3. Edit the entry, uncheck Disable, then click Save.

This results in the page timing out, but the entry being updated.

Similar issue to https://redmine.pfsense.org/issues/12870


Related issues

Is duplicate of Bug #12870: Clicking Save & Force Update on a Dynamic DNS entry results in a GUI timeoutResolvedJim Pingle

Actions
Actions #1

Updated by Marcos M 3 months ago

  • Private changed from Yes to No
Actions #2

Updated by Kris Phillips 3 months ago

I am unable to recreate this issue on the Nov 11th builds of 23.01. When clicking save or save and force update after toggling the disabled checkbox, I get to the main DDNS page immediately and without any hang up.

1. I created a test GW Group with one gateway in it
2. Created the DDNS entry as described above
3. Enabled and clicked Save on the entry. Page loaded as expected.
4. I then disabled it again, saved, and re-enabled and tried save with force update. Page also loaded as expected.

Probably something hanging on the process when the remote end doesn't respond fast enough. Maybe a timeout needs to be added here.

Actions #3

Updated by Jim Pingle 2 months ago

  • Status changed from New to Feedback
  • Assignee set to Jim Pingle
  • Target version set to 2.7.0
  • Plus Target Version set to 23.01

The new fix on #12870 probably fixed this as well, try with 02d6ca03965777ab95da05c7ae526aa75d2ddc2a applied or on a snapshot with that built in.

Actions #4

Updated by Marcos M 2 months ago

  • Status changed from Feedback to Resolved

Worked well here, thanks!

Actions #5

Updated by Marcos M 2 months ago

  • Is duplicate of Bug #12870: Clicking Save & Force Update on a Dynamic DNS entry results in a GUI timeout added
Actions #6

Updated by Marcos M 2 months ago

  • Status changed from Resolved to Duplicate
Actions #7

Updated by Jim Pingle 13 days ago

  • Target version deleted (2.7.0)
  • Plus Target Version deleted (23.01)
Actions

Also available in: Atom PDF