Project

General

Profile

Actions

Regression #13604

closed

OpenVPN service status is incorrect

Added by Marcos M 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Services
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:

Description

On 22.05, stopping an OpenVPN service under Status / OpenVPN results in a red "OpenVPN Service is Stopped" icon. On 23.01, it now shows a yellow "OpenVPN Service is Disabled" icon even though the configuration entry is not disabled.

Actions #1

Updated by Danilo Zrenjanin 3 months ago

  • Status changed from New to Confirmed

I confirmed this behavior on the:

23.01-DEVELOPMENT (amd64)
built on Wed Nov 16 06:05:08 UTC 2022
FreeBSD 14.0-CURRENT
Actions #2

Updated by Jim Pingle 3 months ago

  • Category changed from Web Interface to Services
  • Status changed from Confirmed to In Progress
  • Assignee set to Jim Pingle
  • Target version set to 2.7.0
  • Plus Target Version set to 23.01

Pretty sure all of these service-related Redmine issues are the same root cause. I see at least one obvious problem that is likely causing it to be incorrect.

Actions #3

Updated by Jim Pingle 3 months ago

Confirmed, they're all the same root cause. Fix committed, will be in momentarily.

Actions #4

Updated by Jim Pingle 3 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #5

Updated by Danilo Zrenjanin 3 months ago

Tested the patch against the following services under Status/Services:

frr, pfb_dnsbl, pfb_filter, radius, openvpn

The patch works as expected!

Actions #6

Updated by Jim Pingle about 2 months ago

  • Release Notes changed from Default to Force Exclusion

Not a problem in a release, excluding from release notes.

Actions #7

Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved

Works as expected.

Actions

Also available in: Atom PDF