Project

General

Profile

Actions

Bug #13675

closed

Code that sets IPv6 MTU can unintentionally act on IPv4 addresses

Added by Christopher Cope 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Related to https://redmine.pfsense.org/issues/11855

The patch on that issue adds a check for the address being IPv6 to the second half, but not to the loop.

Nov 16 21:50:26 ldex-fw2 php[386]: rc.bootup: The command '/sbin/route 
change -6 -mtu '9000' '192.168.101.0/24' '192.168.9.1'' returned exit 
code '71', the output was 'route: 192.168.101.0: Name does not resolve'

This is causing the boot up to stick on "Configuring VLAN interfaces..." for an extended period of time. I am able to reproduce using the config of a customer who is hitting this issue. I have made a patch that adds the additional check in and fixes the issue. I will submit a merge request for review shortly.


Related issues

Related to Bug #11855: Error when changing MTU if the interface is used for both IPv4 and IPv6 default routesResolvedViktor Gurov04/27/2021

Actions
Actions #1

Updated by Christopher Cope 3 months ago

  • Related to Bug #11855: Error when changing MTU if the interface is used for both IPv4 and IPv6 default routes added
Actions #2

Updated by Christopher Cope 3 months ago

  • Status changed from New to Pull Request Review
Actions #3

Updated by Jim Pingle 2 months ago

  • Target version set to 2.7.0
  • Plus Target Version set to 23.01
Actions #4

Updated by Christopher Cope 2 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #5

Updated by Lev Prokofev 2 months ago

Not able to reproduce it on 23.01-DEVELOPMENT (amd64) built on Fri Nov 11 using the config from customer ticket.

Actions #6

Updated by Jim Pingle about 2 months ago

  • Subject changed from IPv6 set MTU code can end up trying to use IPv4 addresses to Code that sets IPv6 MTU can unintentionally act on IPv4 addresses

Updating subject for release notes.

Actions #7

Updated by Jim Pingle about 1 month ago

  • Status changed from Feedback to Resolved

Closing based on the note above saying it was tested successfully.

Actions

Also available in: Atom PDF