Project

General

Profile

Actions

Bug #13684

closed

HAProxy PHP error haproxy.inc:1229

Added by Steve Wheeler 2 months ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
haproxy
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
2.7.0
Affected Plus Version:
23.01
Affected Architecture:
All

Description

On upgrade to 2.7:

PHP errors
PHP ERROR: Type: 1, File: /usr/local/pkg/haproxy/haproxy.inc, Line: 1229, Message: Uncaught Error: Non-static method haproxy_utils::query_dns() cannot be called statically in /usr/local/pkg/haproxy/haproxy.inc:1229
Stack trace:
#0 /usr/local/pkg/haproxy/haproxy.inc(2096): write_backend('/var/etc/haprox...', Resource id #89, 'NextCloud_ipvAN...', Array, Array)
#1 /usr/local/pkg/haproxy/haproxy.inc(2353): haproxy_writeconf('/var/etc/haprox...')
#2 /usr/local/pkg/haproxy/haproxy.inc(653): haproxy_check_run(1)
#3 /etc/inc/pkg-utils.inc(779) : eval()'d code(1): haproxy_custom_php_install_command()
#4 /etc/inc/pkg-utils.inc(779): eval()
#5 /etc/inc/pkg-utils.inc(897): eval_once('haproxy_custom_...')
#6 /etc/rc.packages(76): install_package_xml('haproxy')
#7 {main}
thrown @ 2022-11-20 17:52:52


Related issues

Is duplicate of Regression #13597: haproxy-devel PHP8 regression when saving a backend entryResolvedMarcos M

Actions
Actions #1

Updated by Robert Johnston 2 months ago

Duplicate of #13562 (with fix in there)

Actions #2

Updated by Marcos M 2 months ago

  • Is duplicate of Regression #13597: haproxy-devel PHP8 regression when saving a backend entry added
Actions #3

Updated by Marcos M 2 months ago

  • Status changed from New to Duplicate
  • Assignee set to Marcos M
Actions #4

Updated by Jim Pingle 2 months ago

  • Target version deleted (2.7.0)
  • Parent task deleted (#13446)
  • Plus Target Version deleted (23.01)
Actions

Also available in: Atom PDF