Project

General

Profile

Actions

Regression #13705

closed

Feature #13446: Upgrade PHP from 7.4 to 8.1

PHP8.1 Captive Portal TypeError

Added by Christopher Cope 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Captive Portal
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:

Description

PHP ERROR: Type: 1, File: /etc/inc/captiveportal.inc, Line: 2354, Message: Uncaught TypeError: implode(): Argument #2 ($array) must be of type ?array, string given in /etc/inc/captiveportal.inc:2354
Stack trace:
#0 /etc/inc/captiveportal.inc(2354): implode('\n', '')
#1 /etc/rc.carpmaster(196): captiveportal_write_usedmacs_db('')
#2 {main}
thrown @ 2022-11-28 17:50:40
Actions #1

Updated by Christopher Cope 2 months ago

Tested on

23.01-DEVELOPMENT (amd64)
built on Thu Nov 24 06:04:19 UTC 2022
FreeBSD 14.0-CURRENT 

Actions #2

Updated by Christian McDonald 2 months ago

  • Status changed from New to Feedback
  • Assignee set to Christian McDonald
  • Target version set to CE-Next
  • Plus Target Version set to Plus-Next
  • Release Notes changed from Default to Force Exclusion
Actions #3

Updated by Jim Pingle 2 months ago

  • Target version changed from CE-Next to 2.7.0
  • Plus Target Version changed from Plus-Next to 23.01
Actions #4

Updated by Jim Pingle 2 months ago

  • Tracker changed from Bug to Regression
Actions #5

Updated by Christopher Cope 2 months ago

  • Status changed from Feedback to Resolved

I was getting this error every few hours. After applying this patch I've went almost 24 hours without an error. Marking resolved.

Actions #6

Updated by Jim Pingle 2 months ago

  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF