Project

General

Profile

Actions

Bug #13953

closed

PHP Error loading Floating rule tab with OpenVPN group rules when there are no OpenVPN instances in the configuration

Added by Christos Messios over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Rules / NAT
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.05
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:

Description

PHP ERROR: Type: 1, File: /usr/local/www/firewall_rules.php, Line: 805, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/firewall_rules.php:805
Stack trace:
#0 {main}


Files

PHP_errors.log (244 Bytes) PHP_errors.log Christos Messios, 02/14/2023 12:54 AM

Related issues

Has duplicate Bug #13982: PHP error: /usr/local/www/firewall_rules.php:805Duplicate

Actions
Actions #1

Updated by Jim Pingle over 1 year ago

  • Project changed from pfSense Plus to pfSense
  • Subject changed from PHP ERROR: Type: 1 to PHP Error loading Floating rule tab with OpenVPN group rules when there are no OpenVPN instances in the configuration
  • Category changed from Rules / NAT to Rules / NAT
  • Priority changed from Normal to Low
  • Target version set to 2.7.0
  • Affected Plus Version deleted (23.01)
  • Plus Target Version set to 23.05
  • Affected Version set to 2.7.0

Looks like maybe you have rules defined for the OpenVPN group on the Floating tab but you have no OpenVPN clients or servers present on that system.

Is that correct?

You can add a dummy client or service entry for the moment and then fix your invalid rules, then delete it again. Or edit them out of the config.

The only way I could reproduce this was:

1. Add an OpenVPN instance
2. Add a floating rule using OpenVPN as its interface
3. Delete the OpenVPN instance
4. Try to view the Floating tab

Actions #2

Updated by Christos Messios over 1 year ago

Jim Pingle wrote in #note-1:

Looks like maybe you have rules defined for the OpenVPN group on the Floating tab but you have no OpenVPN clients or servers present on that system.

Is that correct?

You can add a dummy client or service entry for the moment and then fix your invalid rules, then delete it again. Or edit them out of the config.

The only way I could reproduce this was:

1. Add an OpenVPN instance
2. Add a floating rule using OpenVPN as its interface
3. Delete the OpenVPN instance
4. Try to view the Floating tab

Worked, thank you!

Actions #3

Updated by Jim Pingle over 1 year ago

  • Has duplicate Bug #13982: PHP error: /usr/local/www/firewall_rules.php:805 added
Actions #4

Updated by Jim Pingle over 1 year ago

  • Assignee set to Jim Pingle
Actions #5

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #6

Updated by Danilo Zrenjanin about 1 year ago

Tested the patch on the:

23.01-RELEASE (amd64)
built on Fri Feb 10 20:06:33 UTC 2023
FreeBSD 14.0-CURRENT

The patch fixes it. I was able to see the floating rule without PHP errors after removing the OpenVPN instance.

I am marking this ticket resolved.

Actions #7

Updated by Danilo Zrenjanin about 1 year ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF