Project

General

Profile

Actions

Bug #13976

closed

SNMP logs "Device not configured" error message when queries involve built-in switch port interfaces

Added by Georgiy Tyutyunnik about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Interfaces
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Release Notes:
Default
Affected Plus Version:
23.01
Affected Architecture:
7100, SG-1100, SG-2100, SG-3100

Description

SNMP polls cause the following errors in system logs:
Feb 17 12:52:11 snmpd 9415 SIOCGIFDESCR (e6000sw0port1): Device not configured
Feb 17 12:52:11 snmpd 9415 SIOCGIFDESCR (e6000sw0port2): Device not configured
Feb 17 12:52:11 snmpd 9415 SIOCGIFDESCR (e6000sw0port3): Device not configured
It affects all models with in-built switch


Related issues

Related to Bug #8600: "snmpd SIOCGIFDESCR (e6000sw0port1): Device not configured"ResolvedLuiz Souza06/26/2018

Actions
Has duplicate Regression #14099: snmpd SIOCGIFDESCR (e6000sw0port1): Device not configuredDuplicate

Actions
Actions #1

Updated by Michael Novotny 12 months ago

Ditto. Same here after upgrading HA 7100's from 22.05 to 23.01.

Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port10): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port9): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port8): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port7): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port6): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port5): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port4): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port3): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port2): Device not configured
Feb 27 07:39:16     snmpd     43744     SIOCGIFDESCR (e6000sw0port1): Device not configured
Actions #2

Updated by Jim Pingle 12 months ago

  • Subject changed from Error messages from snmpd on boards with in-built switches to SNMP logs "Device not configured" error message when queries involve built-in switch port interfaces
  • Category changed from SNMP to Interfaces
  • Assignee set to Luiz Souza
  • Target version set to 23.05
  • Start date deleted (02/17/2023)

This appears to be the same as #8600 and to fix it then, we suppressed that error.

Actions #3

Updated by Jim Pingle 12 months ago

  • Related to Bug #8600: "snmpd SIOCGIFDESCR (e6000sw0port1): Device not configured" added
Actions #4

Updated by Jim Pingle 12 months ago

  • Has duplicate Regression #14099: snmpd SIOCGIFDESCR (e6000sw0port1): Device not configured added
Actions #5

Updated by Manuel M. 11 months ago

I have the same on my Netgate 7100. Hope there is a fix soon because this ** is flooding mit logs :/

Actions #6

Updated by Jim Pingle 10 months ago

The last time we fixed this appears to be in src commit b33b6cb8a704be9c4053ca4f050357cd9eb0a13d (Internal link: https://gitlab.netgate.com/pfSense/FreeBSD-src/-/commit/b33b6cb8a704be9c4053ca4f050357cd9eb0a13d ) but that diff doesn't pick cleanly onto a current tree, so may need some adapting. It was a one-line change, though, so hopefully simple.

Actions #7

Updated by Jim Pingle 10 months ago

It looks like this would be a current equivalent change:

diff --git a/contrib/bsnmp/snmp_mibII/mibII.c b/contrib/bsnmp/snmp_mibII/mibII.c
index 2a4e3756bdc5..d003e0b12797 100644
--- a/contrib/bsnmp/snmp_mibII/mibII.c
+++ b/contrib/bsnmp/snmp_mibII/mibII.c
@@ -563,7 +563,7 @@ mib_fetch_ifmib(struct mibif *ifp)
        if (ioctl(mib_netsock, SIOCGIFDESCR, &irr) == -1) {
                free(ifp->alias);
                ifp->alias = NULL;
-               if (errno != ENOMSG)
+               if (errno != ENOMSG && errno != ENXIO)
                        syslog(LOG_WARNING, "SIOCGIFDESCR (%s): %m", ifp->name);
        } else if (irr.ifr_buffer.buffer == NULL) {
                free(ifp->alias);

But someone more familiar with the code than I should look that over first.

Actions #8

Updated by Luiz Souza 10 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Fixed.

Actions #9

Updated by Christian McDonald 10 months ago

  • Status changed from Feedback to Resolved
Actions #10

Updated by Jim Pingle 10 months ago

Before upgrading to the current snapshot:

$ snmpwalk -v 2c -c public 198.51.100.24 ifName

May  3 09:59:53 ood snmpd[58869]: SIOCGIFDESCR (e6000sw0port0): Device not configured
May  3 09:59:53 ood snmpd[58869]: SIOCGIFDESCR (e6000sw0port1): Device not configured
May  3 09:59:53 ood snmpd[58869]: SIOCGIFDESCR (e6000sw0port2): Device not configured
May  3 09:59:53 ood snmpd[58869]: SIOCGIFDESCR (e6000sw0port3): Device not configured

After upgrading to the current snapshot there are no errors in the log when running the same command.

Actions

Also available in: Atom PDF