Project

General

Profile

Actions

Feature #14002

closed

Option to enable/disable console bell, enabled by default

Added by Steve Wheeler about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Authentication
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.05
Release Notes:
Default

Description

In 23.01 logging into the firewall no longer sounds a beep from the speaker is it's present.

This is because the default value for system bell has changed.

It can be restored by setting the system tunable / sysctl:

kern.vt.enable_bell=1

We should consider setting this as the default.

See also this which is required to trigger the beep for logins: https://redmine.pfsense.org/issues/12464


Related issues

Related to Feature #12464: Option to control log level of authentication messages in system logs ("Emergency" vs "Notice" level)ResolvedJim Pingle

Actions
Related to Regression #14025: 23.01 and "bip" missingDuplicate

Actions
Actions #1

Updated by Jim Pingle about 1 year ago

  • Related to Feature #12464: Option to control log level of authentication messages in system logs ("Emergency" vs "Notice" level) added
Actions #2

Updated by Jim Pingle about 1 year ago

Actions #3

Updated by Jim Pingle about 1 year ago

  • Assignee set to Jim Pingle
Actions #4

Updated by Jim Pingle about 1 year ago

  • Subject changed from Logins no longer trigger a beep to Console bell disabled by default
  • Status changed from New to In Progress

The more I look at this the less it's tied to the login messages since it's a general console bell setting. I've got a patch ready that adds a new option under "Sounds" on system_advanced_notifications.php to control the console bell directly. I've defaulted it to enabled, so once upgraded to a snapshot with the change (or after applying the patch), it will be enabled at boot and when saving settings on system_advanced_notifications.php.

Actions #5

Updated by Jim Pingle about 1 year ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #6

Updated by Danilo Zrenjanin about 1 year ago

  • Status changed from Feedback to Resolved

Tested the patch against:

23.01-RELEASE (amd64)
built on Fri Feb 10 20:06:33 UTC 2023
FreeBSD 14.0-CURRENT

The GUI option appears, and it works as expected. I am marking this ticket resolved.

Actions #7

Updated by Jim Pingle 12 months ago

  • Tracker changed from Regression to Feature
  • Subject changed from Console bell disabled by default to Option to enable/disable console bell, enabled by default
  • Affected Architecture deleted (All)

Changing this to a feature request. Even though it started as a way to address a regression, the change involved is a new feature, so this will better reflect the change in the release notes.

Actions

Also available in: Atom PDF