Project

General

Profile

Actions

Todo #14399

closed

Combining Interface and Rule ID state table filter fields returns no results

Added by Chris W 11 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Diagnostics
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Default

Description

Steps to reproduce:

1. Diagnostics > States. Leave everything default (Interface: all, Filter expression and Rule ID fields blank) and click Filter. That will show all open states on the system, as expected.

2. Grab a rule ID from ..status.php#FirewallpfFirewallRules. In this case I'm using the default anti-lockout rule on the LAN interface (rule 79).

3. With Interface set to all, enter 79 for the Rule ID. This shows open states for the rule when I log in to the GUI.

4. Now set the Interface dropdown to LAN, keeping the Rule ID. Nothing is shown when applying the filter. If I remove the Rule ID and rerun the filter on just the LAN, the states are returned again as expected.


Files

Screenshot from 2023-05-19 12-18-26.png (42.7 KB) Screenshot from 2023-05-19 12-18-26.png Interface: LAN, Rule ID 79 Chris W, 05/19/2023 06:56 PM
Screenshot from 2023-05-19 12-18-33.png (64.6 KB) Screenshot from 2023-05-19 12-18-33.png Interface: all, Rule ID 79 Chris W, 05/19/2023 06:56 PM
Screenshot from 2023-05-19 12-18-17.png (105 KB) Screenshot from 2023-05-19 12-18-17.png Interface: LAN, Rule ID blank Chris W, 05/19/2023 06:56 PM
Actions #1

Updated by Steve Wheeler 11 months ago

This is not a bug it's the expected behaviour. Probably just not implemented yet:
https://github.com/pfsense/FreeBSD-ports/blob/devel/devel/php-pfSense-module/files/pfSense.c#L2756

        if (filter_if && filter_rl)
            RETURN_NULL();

Actions #2

Updated by Chris W 11 months ago

  • Tracker changed from Bug to Todo
  • Affected Plus Version deleted (23.01)
Actions #3

Updated by Steve Wheeler 11 months ago

  • Status changed from New to Confirmed
  • Target version set to 23.09

The page should return an error indicating that search combination is invalid.

Actions #4

Updated by Jim Pingle 8 months ago

  • Project changed from pfSense Plus to pfSense
  • Category changed from Web Interface to Diagnostics
  • Status changed from Confirmed to In Progress
  • Assignee set to Jim Pingle
  • Target version changed from 23.09 to 2.8.0
  • Plus Target Version set to 23.09

Not specific to plus

I'll add an input validation error if both are filled in.

Actions #5

Updated by Jim Pingle 8 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #6

Updated by Jim Pingle 8 months ago

  • Status changed from Feedback to Resolved

Input validation error is printed as expected, other queries still work.

Actions #7

Updated by Jim Pingle 6 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF