Project

General

Profile

Actions

Regression #14735

closed

``arp`` command is not filtering output as expected, behavior changed in FreeBSD

Added by Christian McDonald 8 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:

Files

clipboard-202308311919-cliyy.png (124 KB) clipboard-202308311919-cliyy.png Danilo Zrenjanin, 08/31/2023 05:19 PM
Actions #1

Updated by Danilo Zrenjanin 8 months ago

I couldn't reproduce it on 23.05.1

It pulled the MAC address from my MacOS interface connected to the firewall.

Actions #2

Updated by Christian McDonald 8 months ago

Seems to be a regression on 23.09

Actions #3

Updated by Danilo Zrenjanin 8 months ago

  • Status changed from New to Confirmed

Ok. I replicated the issue on:

23.09-DEVELOPMENT (amd64)
built on Sat Aug 26 04:50:14 UTC 2023
FreeBSD 14.0-ALPHA2

I am changing the status to confirmed.

Actions #4

Updated by Jim Pingle 7 months ago

  • Category changed from DHCP (IPv4) to Operating System

The problem here is that the behavior of the arp command has changed. Running arp -n <ip addr> used to limit the output to only the row for that IP address. Now it's returning all of them as if it was run with -a. Because it's returning all of the entries, the firewall itself is first, which is where it gets that MAC address from.

Looks like a bug in arp on FreeBSD to me. We could work around it, but given how broken the current behavior is, it would be better to get it fixed upstream.

Actions #5

Updated by Jim Pingle 7 months ago

  • Subject changed from ```Copy My MAC``` returns MAC of firewall instead of client to ``arp`` command is not filtering output as expected, behavior changed in FreeBSD
Actions #6

Updated by Christian McDonald 7 months ago

  • Status changed from Confirmed to Waiting on Merge
Actions #7

Updated by Jim Pingle 7 months ago

  • Target version changed from CE-Next to 2.8.0
Actions #8

Updated by Christian McDonald 7 months ago

  • Status changed from Waiting on Merge to Feedback
Actions #9

Updated by Danilo Zrenjanin 7 months ago

  • Status changed from Feedback to Resolved

I have conducted a test on the most recent build today and can verify that it is performing as expected.

I am marking this ticket closed.

Actions #10

Updated by Jim Pingle 7 months ago

For good measure I also tested out the arp fixes and everything is working properly as far as I can see now.

Manually at the CLI I can filter by address and by interface.

The 'Copy My MAC' button on DHCP static mappings also works as expected from a directly connected client.

Actions #11

Updated by Jim Pingle 6 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF