Project

General

Profile

Actions

Bug #14782

closed

RFC 2136 Dynamic DNS client selects a virtual IPv6 address instead of statically configured WAN Ipv6 address

Added by M Felden 9 months ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:

Description

2.7.0

WAN IPv6 address set statically. 2001:db8:5000:5::1/64. Gateway is fe80:: with an interface route %vtnet0

There is also a virtual IPv6 address defined and bound to WAN. It is 2001:db8:1:2::1/128.

The instance announces 2001:db8:1::/48 via BGP.

RFC2136 client is set up to monitor WAN interface, update Ipv4 and Ipv4 addresses. "Use public IP is checked". "Update Source" and "Update Source Family" are default.

Expected Behavior:

It should update the AAAA record with the Ipv6 address that is configured in /interfaces.php?if=wan

Actual Behavior:

It updates the record with the virtual IP address.

Possible clue:

I have replicated this on several instances until I found one that is NOT effected. The difference is that the instance that works as expected has the IPv6 gateway clearly defined as ::1 of its /64 whereas the instances that misbehave have the IPv6 default gateway set as an interface route to fe80::


Related issues

Is duplicate of Regression #14623: Primary interface address is incorrectly set to the last address on the interfaceResolvedMarcos M

Actions
Actions #1

Updated by Jim Pingle 9 months ago

  • Status changed from New to Duplicate

Looks like it's almost certainly a duplicate of #14623

Actions #2

Updated by Jim Pingle 9 months ago

  • Is duplicate of Regression #14623: Primary interface address is incorrectly set to the last address on the interface added
Actions

Also available in: Atom PDF