Project

General

Profile

Actions

Bug #14929

closed

``choparp`` service is not stopped after deleting Proxy ARP type Virtual IP addresses

Added by Jared Hendrickson 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Virtual IP Addresses
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
24.03
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:

Description

After deleting a ProxyARP virtual IP, the choparp process is still running. To reproduce:

1. Create a new single address ProxyARP virtual IP and apply it. For this example, I created a virtual IP for 192.168.1.150/32.
2. Run ps aux | grep choparp which show the virtual IP is running as expected: root 65423 0.0 0.3 13392 3244 - S 20:28 0:00.00 /usr/local/sbin/choparp -p /var/run/choparp_em0.pid em0 auto 192.168.1.150/32
3. Delete the virtual IP and rerun ps aux | grep choparp. The process for the deleted virtual IP is still running: root 65423 0.0 0.3 13392 3244 - S 20:28 0:00.00 /usr/local/sbin/choparp -p /var/run/choparp_em0.pid em0 auto 192.168.1.150/32

This appears to happen because interface_proxyarp_configure() is called before deleting the virtual IP from configuration, which results in the choparp process being re-spawned.

Actions #1

Updated by Danilo Zrenjanin 4 months ago

  • Status changed from Pull Request Review to Confirmed

I can confirm this behavior on the:

23.05.1-RELEASE (amd64)
built on Wed Jun 28 03:57:27 UTC 2023
FreeBSD 14.0-CURRENT

Actions #2

Updated by Jared Hendrickson 4 months ago

Forgot to add link to PR in case it's needed: https://github.com/pfsense/pfsense/pull/4652

Actions #3

Updated by Danilo Zrenjanin 4 months ago

I tested the patch, and I can confirm that it fixes the issue.

Actions #4

Updated by Jim Pingle 4 months ago

  • Subject changed from choparp process is not killed after deleting ProxyARP virtual IP to ``choparp`` service is not stopped after deleting Proxy ARP type Virtual IP addresses
  • Target version set to 2.8.0
  • Plus Target Version set to 24.03
Actions #5

Updated by Jim Pingle 4 months ago

  • Status changed from Confirmed to Pull Request Review
Actions #6

Updated by Marcos M 3 months ago

  • Status changed from Pull Request Review to Feedback

Applied in changeset 9e8a0841716c1f27698c2321816f92632d004d70.

Actions #7

Updated by Danilo Zrenjanin 3 months ago

  • Status changed from Feedback to Resolved

I couldn't replicate the issue in 23.09.

I am marking this ticket as resolved.

Actions

Also available in: Atom PDF