Project

General

Profile

Bug #1535

Special Characters in IPsec PSK can cause problems

Added by Jim Pingle about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
IPsec
Target version:
Start date:
05/17/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:
All

Description

A customer reported that having any PSK with special characters caused problems with all mobile clients connecting and passing traffic properly.

Specifically the "!" character seems to be problematic, but may also be any of $@*%.

Need to reproduce this and reject the character from the PSK in the GUI if necessary.

History

#1 Updated by Pierre POMES about 8 years ago

Note: I am currenlty using '%', '@' and '.' as non-letter/digit character on a 1.2.3 pfSense system, with a Juniper remote endpoint.

So at leat all of these are valid.

Pierre

#2 Updated by Chris Buechler about 8 years ago

I've used a wide range of special characters too without any issues. Maybe a client side issue in this case? Or maybe specific to mobile clients.

#3 Updated by Jim Pingle about 8 years ago

  • Status changed from New to Feedback

A client-side issue seems more likely. I put special characters all over a PSK and I was still able to connect and pass traffic over a mobile client connection.

#4 Updated by Jim Pingle about 8 years ago

  • Status changed from Feedback to Closed

This was something else entirely, a red herring.

Also available in: Atom PDF