Project

General

Profile

Actions

Feature #15412

closed

Improve error feedback from pfSense-upgrade

Added by Steve Wheeler 2 months ago. Updated 5 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Upgrade
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Force Exclusion

Description

Recent versions of pfSense-upgrade include code for collecting handling errors in order to present it to the user as useful feedback.

It will currently alert to drive space errors and bootloader install errors specifically. It can also show unknown errors which is better than having to dig though logs but can be improved.

One error it may show is:

Upgrade

    check_upgrade (3): unknown error @ 2024-04-16 15:12:00

It's unclear which code path creates that but it should be handled better.

Also see: https://redmine.pfsense.org/issues/15407


Files

4100-upgrade.jpg (50.3 KB) 4100-upgrade.jpg Craig Coonrad, 04/21/2024 06:20 AM

Related issues

Related to Regression #15407: pfSense-upgrade incorrectly creates 'unknown error' notice.ResolvedSteve Wheeler

Actions
Actions #1

Updated by Steve Wheeler 2 months ago

  • Related to Regression #15407: pfSense-upgrade incorrectly creates 'unknown error' notice. added
Actions #3

Updated by Craig Coonrad 2 months ago

I encountered this on clean install to 4100 with: pfSense-plus-memstick-serial-24.03-RELEASE-amd64.img.
The error was generated while the device did not have DNS service. Once DNS service restored, the error resolved.

If the error could have flagged a DNS issue that would be nice.

Actions #4

Updated by Marcos M 20 days ago

  • Status changed from New to Pull Request Review
  • Assignee set to Marcos M

It's not really practical to implement root cause tests in this case, but we can expose what part of the process failed. For example:

check_upgrade: "Updating repositories metadata" returned error code 1 @ 2024-06-05 17:19:30

https://gitlab.netgate.com/pfSense/factory-ports/-/merge_requests/105

Actions #5

Updated by Marcos M 5 days ago

  • Status changed from Pull Request Review to Resolved
  • Release Notes changed from Default to Force Exclusion
Actions

Also available in: Atom PDF