Bug #1696

Panic when finishing setup wizard with PPPoE WAN

Added by Chris Buechler almost 3 years ago. Updated over 2 years ago.

Status:Resolved Start date:07/19/2011
Priority:High Due date:
Assignee:- % Done:

100%

Category:Operating System
Target version:2.0
Affected version:2.0 Affected Architecture:

Description

By going through the setup wizard and changing the WAN type to PPPoE, or just changing the PPPoE username and password, after clicking reload at the end of the setup wizard the system will panic as shown in the attached.

pppoepanic.png (8.1 kB) Chris Buechler, 07/19/2011 01:31 am

pppoepanic-bt.png (11.9 kB) Chris Buechler, 07/19/2011 01:31 am

pppoepanic2-bt.png (15.2 kB) Chris Buechler, 09/06/2011 09:44 pm

Associated revisions

Revision 4ce68cb2
Added by Chris Buechler almost 6 years ago

touch up text.

ticket #1696

Revision bd1dcabd
Added by Chris Buechler almost 6 years ago

touch up text.

ticket #1696

Revision 851083bd
Added by Ermal Luçi over 2 years ago

Fixes #1696. Do not store temporary information under interfaces section during wizards since this might generate a message to netgraph that triggers a panic.

Revision 43d8f1cc
Added by Ermal Luçi over 2 years ago

Fixes #1696. Do not store temporary information under interfaces section during wizards since this might generate a message to netgraph that triggers a panic.

Revision 8678130d
Added by Jim P over 2 years ago

If we are coming from a PPPoE/PPTP WAN type, grab the old physical interface first to avoid assigning a ppp interface to itself. Fixes pppoe->pppoe wizard run as well as changing pppoe->dhcp. Fixes #1696

Revision 75bb4bc3
Added by Jim P over 2 years ago

If we are coming from a PPPoE/PPTP WAN type, grab the old physical interface first to avoid assigning a ppp interface to itself. Fixes pppoe->pppoe wizard run as well as changing pppoe->dhcp. Fixes #1696

Revision 55a14b68
Added by Ermal Luçi over 2 years ago

Another try at prventing panic on reconfig of ppp type wans. Ticket #1696

Revision afe88d69
Added by Ermal Luçi over 2 years ago

Another try at prventing panic on reconfig of ppp type wans. Ticket #1696

Revision d3ce6a8b
Added by Jim P over 2 years ago

Revert "Another try at prventing panic on reconfig of ppp type wans. Ticket #1696"

This reverts commit afe88d69235f84530ed6386b22cfc9c488bf94c5.

Revision 696874d2
Added by Jim P over 2 years ago

Revert "Another try at prventing panic on reconfig of ppp type wans. Ticket #1696"

This reverts commit 55a14b686d8f35d03b87efdbddacb656a04f5bed.

History

#1 Updated by Jim P over 2 years ago

Does this happen on current snapshots? I can't reproduce this in a VM.

#2 Updated by Chris Buechler over 2 years ago

I can still replicate this. If the WAN is set to PPPoE and you run through the setup wizard leaving the same settings, it panics after reloading at the last step of the wizard.

#3 Updated by Jim P over 2 years ago

I was finally able to reproduce this in a VM, even when the WAN was initially set for DHCP. Same panic message/backtrace.

#4 Updated by Ermal Luçi over 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Applied in changeset commit:db74464bf6f980c5c5845d53624d4c6f1b139fa7.

#5 Updated by Chris Buechler over 2 years ago

no change

#6 Updated by Ermal Luçi over 2 years ago

  • Status changed from New to Feedback

#8 Updated by Jim P over 2 years ago

  • Status changed from Feedback to New

Panic still happens even after a gitsync picking up these changes. First run through the wizard (going from DHCP to PPPoE) worked for me, second run that was PPPoE to start and ended PPPoE resulted in a crash.

After reboot, doing a single run again (PPPoE to PPPoE) still crashes.

#9 Updated by Jim P over 2 years ago

  • Status changed from New to Feedback

#10 Updated by Jim P over 2 years ago

#11 Updated by Chris Buechler over 2 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF