Project

General

Profile

Bug #173

Missing input validation for gateways

Added by Chris Buechler over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Gateways
Target version:
Start date:
11/20/2009
Due date:
% Done:

70%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

system_gateways_edit.php does not sanity check entries. Two checks should be added:

1) The gateway IP is within the IP subnet of the interface selected
2) The monitor IP is not used on any other gateway (otherwise the static routes can't be added properly)

Associated revisions

Revision b29b1a33 (diff)
Added by Chris Buechler over 9 years ago

fix input validation of gateways. Ticket #173

Revision 360d6b44 (diff)
Added by Sjon Hortensius about 4 years ago

remove unused variables refs #173

History

#1 Updated by Seth Mos over 9 years ago

  • Status changed from New to Feedback
  • Assignee set to Seth Mos
  • % Done changed from 0 to 100

.

#2 Updated by Seth Mos over 9 years ago

  • Status changed from Feedback to New
  • % Done changed from 100 to 0

#3 Updated by Seth Mos over 9 years ago

Seth Mos wrote:
The monitor IP check was caused by a incorrect variable name which was fixed in #166.

Adding code for subnet check and comitting that.

#4 Updated by Seth Mos over 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 70

#5 Updated by Perry Mason over 9 years ago

unexpected ',' on line 97

#6 Updated by Seth Mos over 9 years ago

The parse error is now gone, but upon further inspection I can create empty array entries by attempting to delete a gateway entry.

#7 Updated by Chris Buechler over 9 years ago

  • Status changed from Feedback to Resolved

the particular issues mentioned in the ticket are fixed after my last commit fixing the input validation

not sure on the empty array entries. If I delete a gateway it is removed properly, the only thing I see is when all gateways are deleted it leaves <gateways></gateways> which shouldn't be a problem from what I see.

Seth, if you know of any other outstanding issues, please open a new ticket.

Also available in: Atom PDF