Project

General

Profile

Actions

Bug #2074

closed

Changing interface IP changes interface assignment as well

Added by Hana Purna almost 10 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
01/06/2012
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0.x
Affected Architecture:

Description

When I change the IP address on my LAN interface through the Set interface(s) IP address in the console, the network card which is associated with the LAN interface changes as well. The result is my LAN interface is not accessible anymore and no routing is working. Other interfaces still work.

It happened on both 2.0 and 2.0.1.

My LAN interface was em1 and after changing the IP address, it was fxp0.
I use PPPoE on the WAN interface to have pfSense handling my ISP public IP address.
fxp0 is the WAN card but is now using pppoe0 "interface". Could it be related? Maybe the anti-lockout rule reset has some relationship with this as well.

Actions #1

Updated by Scott Whitlock over 9 years ago

I can confirm an almost identical problem.

I have pfSense configured with 2 dual NIC cards:

  • bge0 -> PPPoE (WAN) to DSL
  • bge1 -> LAN
  • em0 -> OPT1 -> wireless
  • em1 -> not enabled

So what happens is, I'm using a different firewall, and I'm about to switch over to using the new pfSense firewall. The old firewall IP is 192.168.0.1. First I disconnect the old one from the DSL and connect the pfSense box to the DSL, and I make sure the pfSense logs in and gets a PPPoE connection. However, the pfSense box is sitting on IP 192.168.0.3 because it's not the gateway yet.

Then I go into the pfSense console, select assign IP to interface, select LAN, and change the IP to 192.168.0.1, bit count 24. It seems to go smoothly, but when the menu screen comes up, it shows that the LAN adapter is now bge0 instead of bge1. Then nothing works! It's quite a mess, so I have to go back to the old firewall, then re-assign my adapters. It's quite a pain.

Actions #2

Updated by Jim Pingle about 9 years ago

  • Status changed from New to Feedback

This may have been corrected by the fixes for ticket #2490 - please re-test on a current snapshot.

Actions #3

Updated by Hana Purna about 9 years ago

I re-tested on the 2.1-BETA0-i386-20121014-1810 snapshot.

Unfortunately, the problem still occurs.

Right after installation and initial interface assignment, I changed the LAN IP from 192.168.1.1 to something I can access: here no problem.
Then I restored my configuration from the webGUI. After the reboot, every interface is setup as expected:
  • WAN: pppoe0
  • LAN: em1
  • OPT1: rl0
  • OPT2: em0
  • OPT3: xl0
I then changed the LAN IP and now I have this:
  • WAN: pppoe0
  • LAN: em0
  • OPT1: rl0
  • OPT2: em0
  • OPT3: xl0

My em0 card is now assigned to two interfaces, LAN and OPT2.

Actions #4

Updated by Renato Botelho almost 9 years ago

  • Status changed from Feedback to New
  • Assignee set to Renato Botelho
Actions #5

Updated by Renato Botelho almost 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #7

Updated by Renato Botelho almost 9 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF