Project

General

Profile

Actions

Bug #2213

closed

Call to undefined function hash() in /etc/inc/auth.inc on line 507

Added by Delete Account almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
User Manager / Privileges
Target version:
Start date:
02/19/2012
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1-IPv6
Affected Architecture:
i386

Description

Attempting to add a new user for captive portal testing purposes. Created a test user and clicked save... received the following error. This system is not going anywhere... let me know what else you may need to further troubleshoot this issue. I did do a bug search prior to registering for redmine and posting this new issue.

Fatal error: Call to undefined function hash() in /etc/inc/auth.inc on line 507

A little background on my current edge device: I am running the 2.1-DEVELOPMENT (i386) and I am perhaps 2 days out of sync with master... I will not sync until instructed otherwise.

Actions #1

Updated by Delete Account almost 10 years ago

Crash report begins. Anonymous machine information:

i386
8.1-RELEASE-p6
FreeBSD 8.1-RELEASE-p6 #0: Mon Dec 12 17:46:02 EST 2011 root@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_Dev.8

Crash report details:

PHP Errors:
[19-Feb-2012 16:00:41] PHP Fatal error: Call to undefined function hash() in /etc/inc/auth.inc on line 507
[19-Feb-2012 16:01:25] PHP Fatal error: Call to undefined function hash() in /etc/inc/auth.inc on line 507

Filename: /var/crash/minfree
2048

Actions #2

Updated by Jim Pingle almost 10 years ago

  • Status changed from New to Closed

This is because you must be using PHP 5.3 on the current code, not PHP 5.2.x. It was switched a while back. See #2115

Actions #3

Updated by Delete Account almost 10 years ago

OK. I'll upgrade to 5.3... I did look at 2115 prior to this submittal. Must have missed the requirement. No worries. Thank you.

Actions #4

Updated by Camille Moncelier almost 10 years ago

This is still a problem. I'm running 2.1-DEVELOPMENT (i386) and php 5.3 and I still have an error. This is due to php 5.3 compiled with --disable-all without --enable-hash

Actions #5

Updated by Jim Pingle almost 10 years ago

See the comment above, this is the wrong ticket to comment on -- this is a dupe of the other ticket. Comments should go there.

Actions #6

Updated by Camille Moncelier almost 10 years ago

#2115 is talking about mhash doesn't it ?

The error I'm experiencing is hash() not being defined. Maybe that's because I'm running 2.1-DEVELOPMENT on Freebsd 8.3 ?

Actions #7

Updated by Jim Pingle almost 10 years ago

If you read the other ticket, you'd see mhash is depreciated, and to be replaced by hash. This error is because of work to fix that ticket, it belongs on the other ticket, as it is the same core issue.

Either way it's been fixed overnight, new images work fine.

Actions #8

Updated by Chris Buechler over 9 years ago

  • Target version changed from 8 to 2.1
Actions

Also available in: Atom PDF