Bug #2527

Miniupnpd starts but isn't working

Added by Cino . almost 2 years ago. Updated about 1 month ago.

Status:Resolved Start date:06/29/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:uPNP
Target version:2.1
Affected version:2.1 Affected Architecture:i386

Description

2.1-BETA0 (i386)
built on Thu Jun 28 04:17:24 EDT 2012
FreeBSD 8.3-RELEASE-p3

Code:

Jun 28 11:20:43 miniupnpd39505: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Jun 28 11:20:43 miniupnpd39505: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Jun 28 11:20:43 miniupnpd39505: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Jun 28 11:20:43 miniupnpd39505: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Jun 28 11:20:41 miniupnpd39505: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Jun 28 11:20:41 miniupnpd39505: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Jun 28 11:20:41 miniupnpd39505: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Jun 28 11:20:41 miniupnpd39505: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Jun 28 11:20:40 miniupnpd39505: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Jun 28 11:20:40 miniupnpd39505: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Jun 28 11:20:40 miniupnpd39505: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Jun 28 11:20:40 miniupnpd39505: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Jun 28 11:20:27 miniupnpd39505: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Jun 28 11:20:27 miniupnpd39505: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Jun 28 11:20:27 miniupnpd39505: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Jun 28 11:20:27 miniupnpd39505: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device

I'll have to downgrade to a different snapshot since copying miniupnpd from last week snapshot didn't fix the issue, so its not the binary. I'm wondering if by removing the patch caused this issue. https://github.com/bsdperimeter/pfsense-tools/commit/0aa9dda62239dda4f6e744155e5e4617c0b2c2b6

Downgraded to Jun 20 snapshot and its working

Post http://forum.pfsense.org/index.php/topic,50971.0.html

History

#1 Updated by Cino . almost 2 years ago

this has been resolved with the latest snapshot. You can close this ticket.

http://forum.pfsense.org/index.php/topic,50971.0.html

#2 Updated by Chris Buechler almost 2 years ago

  • Status changed from New to Resolved

#4 Updated by Irving Popovetsky almost 2 years ago

Confirmed broken again on July 10th snapshot.

#5 Updated by Jim P almost 2 years ago

I recompiled it after doing a slightly different preparation method this time, so hopefully the next snapshot is better.

#6 Updated by Brian Carpenter over 1 year ago

Not sure if it is the same issue or not, but I noticed that miniupnpd wasn't working in the 7/13 build, so I updated to the 7/21 build and I'm still seeing it not starting up..

2.1-BETA0 (amd64)
built on Sat Jul 21 15:31:46 EDT 2012
FreeBSD 8.3-RELEASE-p3

Jul 22 10:49:04 miniupnpd56051: DIOCGETSTATUS: Operation not supported by device
Jul 22 10:49:04 miniupnpd56051: DIOCGETSTATUS: Operation not supported by device
Jul 22 10:49:04 miniupnpd56051: Failed to init redirection engine. EXITING
Jul 22 10:49:04 miniupnpd56051: Failed to init redirection engine. EXITING
Jul 22 10:49:12 miniupnpd2786: DIOCGETSTATUS: Operation not supported by device
Jul 22 10:49:12 miniupnpd2786: DIOCGETSTATUS: Operation not supported by device
Jul 22 10:49:12 miniupnpd2786: Failed to init redirection engine. EXITING
Jul 22 10:49:12 miniupnpd2786: Failed to init redirection engine. EXITING

#7 Updated by Kaishi Axon over 1 year ago

Want to confirm that miniupnpd is not working in 7/23 build either.

2.1-BETA0 (amd64)
built on Mon Jul 23 20:21:35 EDT 2012
FreeBSD 8.3-RELEASE-p3

Jul 24 13:19:47 miniupnpd26772: Failed to init redirection engine. EXITING
Jul 24 13:19:47 miniupnpd26772: Failed to init redirection engine. EXITING
Jul 24 13:19:47 miniupnpd26772: DIOCGETSTATUS: Operation not supported by device
Jul 24 13:19:47 miniupnpd26772: DIOCGETSTATUS: Operation not supported by device

#8 Updated by Maxim Luppov over 1 year ago

2.1-BETA0 (i386)
built on Tue Jul 24 18:28:37 EDT 2012
FreeBSD 8.3-RELEASE-p3

ul 25 16:20:59 miniupnpd13405: Failed to init redirection engine. EXITING
Jul 25 16:20:59 miniupnpd13405: Failed to init redirection engine. EXITING
Jul 25 16:20:59 miniupnpd13405: DIOCGETSTATUS: Operation not supported by device
Jul 25 16:20:59 miniupnpd13405: DIOCGETSTATUS: Operation not supported by device

Same problem.

#9 Updated by Maxim Luppov over 1 year ago

Any news on this?

#10 Updated by Kaishi Axon over 1 year ago

Still broken in:

2.1-BETA0 (amd64)
built on Thu Jul 26 22:35:25 EDT 2012
FreeBSD 8.3-RELEASE-p3

#11 Updated by Yan Triary over 1 year ago

Snapshot from 26 July

Jul 27 20:38:16 php: /pkg_edit.php: miniupnpd: Starting service on interface: lan, opt1
Jul 27 20:38:16 miniupnpd[57202]: DIOCGETSTATUS: Operation not supported by device
Jul 27 20:38:16 miniupnpd[57202]: DIOCGETSTATUS: Operation not supported by device
Jul 27 20:38:16 miniupnpd[57202]: Failed to init redirection engine. EXITING
Jul 27 20:38:16 miniupnpd[57202]: Failed to init redirection engine. EXITING

#12 Updated by Chris Buechler over 1 year ago

  • Category changed from Unknown to uPNP
  • Status changed from Resolved to New

#13 Updated by Kaishi Axon over 1 year ago

Regarding tonight's snapshot:

2.1-BETA0 (amd64)
built on Tue Jul 31 18:19:12 EDT 2012
FreeBSD 8.3-RELEASE-p3

miniupnpd seems to be working. I'm not getting errors anymore. Might just be me, and I haven't done thorough testing, but I wanted to pass up the report.

#14 Updated by Ermal Luçi over 1 year ago

Yeah from testing done from us it seemed just wrong build on previous snapshots.

#15 Updated by Ermal Luçi over 1 year ago

  • Status changed from New to Feedback

#16 Updated by Maxim Luppov over 1 year ago

2.1-BETA0 (i386)
built on Tue Jul 31 19:07:24 EDT 2012
FreeBSD 8.3-RELEASE-p3

Aug 1 09:56:03 miniupnpd9254: Failed to init redirection engine. EXITING
Aug 1 09:56:03 miniupnpd9254: Failed to init redirection engine. EXITING
Aug 1 09:56:03 miniupnpd9254: DIOCGETSTATUS: Operation not supported by device
Aug 1 09:56:03 miniupnpd9254: DIOCGETSTATUS: Operation not supported by device

Not working.

#17 Updated by Yan Triary over 1 year ago

built on Tue Jul 31 18:19:12 EDT 2012

problem solved

Aug 1 14:40:05 php: : miniupnpd: Starting service on interface: lan, opt1
Aug 1 14:40:05 miniupnpd[7715]: HTTP listening on port 2189

but

Aug 1 14:42:54 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 1 14:42:54 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 1 14:42:54 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
etc...etc...etc

#18 Updated by Maxim Luppov over 1 year ago

it's not!

2.1-BETA0 (i386)
built on Wed Aug 1 03:29:59 EDT 2012
FreeBSD 8.3-RELEASE-p3

Aug 1 15:48:45 miniupnpd60381: Failed to init redirection engine. EXITING
Aug 1 15:48:45 miniupnpd60381: Failed to init redirection engine. EXITING
Aug 1 15:48:45 miniupnpd60381: DIOCGETSTATUS: Operation not supported by device
Aug 1 15:48:45 miniupnpd60381: DIOCGETSTATUS: Operation not supported by device
etc...etc...etc

#19 Updated by Cino . over 1 year ago

We have 1 AMD64 saying its working and 2 i386 saying its not working.

Even tho its started on AMD64 builds, are ports being opened when you go to the status page? I'm thinking its not because another user reported errors after it started

Is this AMD64 or i386?
Yan Triary wrote:

built on Tue Jul 31 18:19:12 EDT 2012

problem solved

Aug 1 14:40:05 php: : miniupnpd: Starting service on interface: lan, opt1
Aug 1 14:40:05 miniupnpd[7715]: HTTP listening on port 2189

but

Aug 1 14:42:54 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 1 14:42:54 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 1 14:42:54 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
etc...etc...etc

#20 Updated by Yan Triary over 1 year ago

2.1-BETA0 (amd64)
built on Wed Aug 1 02:42:26 EDT 2012
FreeBSD 8.3-RELEASE-p3

Aug 2 00:50:53 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 2 00:50:53 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 2 00:50:54 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 2 00:50:54 miniupnpd[7715]: ioctl(dev, DIOCGETADDRS, ...): Device busy

Actual

#21 Updated by Kaishi Axon over 1 year ago

Okay, as a follow-up: I'm getting these same errors too. My initial response was due to miniupnpd actually starting and staying active for longer than a second. Please set this issue back to NEW!

2.1-BETA0 (amd64)
built on Wed Aug 1 02:42:26 EDT 2012
FreeBSD 8.3-RELEASE-p3

Aug 2 00:19:21 miniupnpd61222: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 2 00:19:21 miniupnpd61222: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 2 00:19:21 miniupnpd61222: ioctl(dev, DIOCGETADDRS, ...): Device busy
Aug 2 00:19:21 miniupnpd61222: ioctl(dev, DIOCGETADDRS, ...): Device busy

#22 Updated by Jim P over 1 year ago

  • Status changed from Feedback to New

Latest snap is better but we may have to disable IPv6.

Aug 2 01:12:55     php: : miniupnpd: Starting service on interface: lan
Aug 2 01:12:55     miniupnpd[37410]: HTTP listening on port 2189
Aug 2 01:12:55     miniupnpd[37410]: HTTP listening on port 2189
Aug 2 01:12:55     miniupnpd[37410]: HTTP IPv6 address given to control points : [2001:xxx:xxxx:3::1]
Aug 2 01:12:55     miniupnpd[37410]: HTTP IPv6 address given to control points : [2001:xxx:xxxx:3::1]
Aug 2 01:12:55     miniupnpd[37410]: setsockopt(udp_notify IPv6, IPV6_MULTICAST_IF, 0): Can't assign requested address
Aug 2 01:12:55     miniupnpd[37410]: setsockopt(udp_notify IPv6, IPV6_MULTICAST_IF, 0): Can't assign requested address
Aug 2 01:12:55     miniupnpd[37410]: Failed to open sockets for sending SSDP notify messages. EXITING
Aug 2 01:12:55     miniupnpd[37410]: Failed to open sockets for sending SSDP notify messages. EXITING

#23 Updated by Yan Triary over 1 year ago

get back

Aug 2 11:52:41 miniupnpd[61172]: HTTP listening on port 2189
Aug 2 11:52:41 miniupnpd[61172]: HTTP listening on port 2189
Aug 2 11:52:41 miniupnpd[61172]: no HTTP IPv6 address
Aug 2 11:52:41 miniupnpd[61172]: no HTTP IPv6 address
Aug 2 11:52:41 miniupnpd[61172]: setsockopt(udp, IPV6_ADD_MEMBERSHIP): Can't assign requested address
Aug 2 11:52:41 miniupnpd[61172]: setsockopt(udp, IPV6_ADD_MEMBERSHIP): Can't assign requested address
Aug 2 11:52:41 miniupnpd[61172]: setsockopt(udp_notify IPv6, IPV6_MULTICAST_IF, 0): Can't assign requested address
Aug 2 11:52:41 miniupnpd[61172]: setsockopt(udp_notify IPv6, IPV6_MULTICAST_IF, 0): Can't assign requested address
Aug 2 11:52:41 miniupnpd[61172]: Failed to open sockets for sending SSDP notify messages. EXITING
Aug 2 11:52:41 miniupnpd[61172]: Failed to open sockets for sending SSDP notify messages. EXITING

#24 Updated by Maxim Luppov over 1 year ago

All this is very very sad :(

#25 Updated by Jim P over 1 year ago

Not sure why you'd consider bugs in a beta release sad, if there were no bugs, it wouldn't be beta :-)

My last commit lets it start up properly now -- though I am unsure if it's actually working still. No pf errors, but I didn't do in-depth testing.

#26 Updated by Maxim Luppov over 1 year ago

Jim P wrote:

Not sure why you'd consider bugs in a beta release sad, if there were no bugs, it wouldn't be beta :-)

My last commit lets it start up properly now -- though I am unsure if it's actually working still. No pf errors, but I didn't do in-depth testing.

See no connection between bugs and beta version. Also bug it's when something working not in the way it meant to. When something is not working at all... it's called not working at all.
Also you could at least specify what version and what build you use. Your logs are worthless without this.

#27 Updated by Jim P over 1 year ago

Maxim Luppov wrote:

See no connection between bugs and beta version.

For us, a beta is actually a beta, not a perpetual product like some companies do (Google). When the system is reasonably free of bugs we move to RC and RELEASE status. BETA0 implies it's early beta and as such will have bugs and other issues, no matter what you prefer to call them.

Also bug it's when something working not in the way it meant to. When something is not working at all... it's called not working at all.

If it's not working at all, it's surely not working the way it want meant to. Both are "bugs" in the sense we use it here. There is no distinction. No need to be pedantic, a bug is a bug.

Also you could at least specify what version and what build you use. Your logs are worthless without this.

The newest snapshot as of the time I posted. If I mentioned I committed a change, you can find the commit in the commit log to see the time on it.

#28 Updated by Maxim Luppov over 1 year ago

Jim P wrote:

Maxim Luppov wrote:

See no connection between bugs and beta version.

For us, a beta is actually a beta, not a perpetual product like some companies do (Google). When the system is reasonably free of bugs we move to RC and RELEASE status. BETA0 implies it's early beta and as such will have bugs and other issues, no matter what you prefer to call them.

Also bug it's when something working not in the way it meant to. When something is not working at all... it's called not working at all.

If it's not working at all, it's surely not working the way it want meant to. Both are "bugs" in the sense we use it here. There is no distinction. No need to be pedantic, a bug is a bug.

Also you could at least specify what version and what build you use. Your logs are worthless without this.

The newest snapshot as of the time I posted. If I mentioned I committed a change, you can find the commit in the commit log to see the time on it.

You can't read???

2.1-BETA0 (i386)
built on Fri Aug 3 01:05:32 EDT 2012
FreeBSD 8.3-RELEASE-p3

Aug 3 16:40:54 miniupnpd57857: Failed to init redirection engine. EXITING
Aug 3 16:40:54 miniupnpd57857: Failed to init redirection engine. EXITING
Aug 3 16:40:54 miniupnpd57857: DIOCGETSTATUS: Operation not supported by device
Aug 3 16:40:54 miniupnpd57857: DIOCGETSTATUS: Operation not supported by device

Where exactly it's working???

Beta is beta. Bug is bug. And this is NOT working daemon.

#29 Updated by Jim P over 1 year ago

And yelling won't fix it any faster, nor will berating/abusing developers. That's a good way to get yourself banned from posting here.

I was testing on amd64.

#30 Updated by Maxim Luppov over 1 year ago

Jim P wrote:

And yelling won't fix it any faster, nor will berating/abusing developers. That's a good way to get yourself banned from posting here.

I was testing on amd64.

I'm yelling at you, not at the developers. And it's very easy to see difference, like between bugged and not working daemon. But not for you obviously. Also banned must be those, who posting wrong conclusions and useless logs of who knows what. Cheers!

#31 Updated by Jim P over 1 year ago

Maxim Luppov wrote:

I'm yelling at you, not at the developers. And it's very easy to see difference, like between bugged and not working daemon. But not for you obviously. Also banned must be those, who posting wrong conclusions and useless logs of who knows what. Cheers!

...and I'm a developer, one of the people trying to debug this and work on it, and you are really making want to ignore the problem for a while. There is zero cause for your attitude here. Goodbye.

#32 Updated by Cino . over 1 year ago

Jim, you have my vote to ban him.. Or lock this bug report so only myself and the developers can comment on since I was the one that submitted the bug report a couple of months ago..

#33 Updated by M L over 1 year ago

Now I see why UPnP still doesn't work. That's because you are "working on it". :D Yes, ban me again, you big scary developer. That's how you solve all your problems, do you?
As I said all this is very very sad. Cheers 1 more time!

#34 Updated by Jim P over 1 year ago

  • Status changed from New to Feedback

Not big and scary, just someone trying to get things done that doesn't want to deal with unappreciative idiots.

Childish behavior notwithstanding, the problem should be solved on new snapshots. (i386 up now, amd64 coming soonish).

#35 Updated by Jim P over 1 year ago

Odd that it works on one of my systems but I updated my Alix and it does not work on there. More feedback from others is needed.

#36 Updated by Phantom F Harlock over 1 year ago

starts for me on i386 now.

#37 Updated by Petri Oksanen over 1 year ago

With version:

2.1-BETA0 (i386)
built on Sun Aug 5 18:24:50 EDT 2012
FreeBSD 8.3-RELEASE-p3

the service starts but:

Aug 6 08:07:32 miniupnpd45096: HTTP listening on port 2189
Aug 6 08:07:32 miniupnpd45096: HTTP listening on port 2189
Aug 6 08:07:32 miniupnpd45096: Listening for NAT-PMP traffic on port 5351
Aug 6 08:07:32 miniupnpd45096: Listening for NAT-PMP traffic on port 5351
Aug 6 08:08:25 miniupnpd45096: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Aug 6 08:08:25 miniupnpd45096: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Aug 6 08:08:25 miniupnpd45096: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Aug 6 08:08:25 miniupnpd45096: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Aug 6 08:08:25 miniupnpd45096: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Aug 6 08:08:25 miniupnpd45096: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Aug 6 08:08:25 miniupnpd45096: Failed to add NAT-PMP 2170 tcp->192.168.10.11:2170 'NAT-PMP 2170 tcp'
Aug 6 08:08:25 miniupnpd45096: Failed to add NAT-PMP 2170 tcp->192.168.10.11:2170 'NAT-PMP 2170 tcp'

#38 Updated by Phantom F Harlock over 1 year ago

oh right forgot to check that is actually works, i get similar output as above.

#39 Updated by Jim P over 1 year ago

Next new snapshot might have a better chance at being OK. If you can't wait and want to try the new binary before the snapshot goes up, see http://forum.pfsense.org/index.php/topic,50971.msg279298.html#msg279298

#40 Updated by Petri Oksanen over 1 year ago

Works with that binary, you're the man! ;)

#41 Updated by Vincent Dupain over 1 year ago

With snapshot running on ALIX 2D13:

2.1-BETA0 (i386) 
built on Sun Aug 5 18:24:43 EDT 2012 

miniupnp is started with no error:

Aug 6 16:05:59    miniupnpd[4571]: HTTP listening on port 2189
Aug 6 16:05:59    miniupnpd[4571]: HTTP listening on port 2189
Aug 6 16:05:59    miniupnpd[4571]: Listening for NAT-PMP traffic on port 5351
Aug 6 16:05:59    miniupnpd[4571]: Listening for NAT-PMP traffic on port 5351

#42 Updated by Vincent Dupain over 1 year ago

Started but not working:

Aug 6 20:48:04    miniupnpd[24527]: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Aug 6 20:48:04    miniupnpd[24527]: ioctl(dev, DIOCGETRULES, ...): Operation not supported by device
Aug 6 20:48:04    miniupnpd[24527]: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device
Aug 6 20:48:04    miniupnpd[24527]: ioctl(dev, DIOCCHANGERULE, ...) PF_CHANGE_GET_TICKET: Operation not supported by device

Vincent Dupain wrote:

With snapshot running on ALIX 2D13:
[...]

miniupnp is started with no error:
[...]

#43 Updated by Jim P over 1 year ago

  • Status changed from Feedback to Resolved

Works for me, and many others on the forum report it to be working now.

#44 Updated by Cino . over 1 year ago

jim thank you for staying on top of this!!! Works great now

#45 Updated by cybermerlin cybermerlin about 1 month ago

miniupnpd2507: DIOCGETSTATUS: Operation not supported by device

after upgrade freebsd to 10.0 release #0 and ports\pkg reinstall

#46 Updated by Jim P about 1 month ago

There aren't any official images for FreeBSD 10.x yet. This ticket was for 2.1 only (and is very old).

Also available in: Atom PDF