Bug #2618


High CPU load, low troughput - VMware ESXi (vSphere 5.0)

Added by Robin Friberg almost 10 years ago. Updated almost 10 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:



I'm having trouble with running pfsense (i386 and amd64) at vSphere ESXi servers.
When I do a speedtest between my workstation and my pfsense, I get 13 Mbit/sec.
If I do the same test between my server (another LAN) and my pfsense, I get 900 Mbit/sec.

If I activate "device polling" on advanced network-settings. I get 30 Mbit/sec, but the CPU-load is 100% constantly. According to pfsense.
"top" says "System" is taking it all.

I tried to do the same test without Open-VM-Tools installed and then i got normal results, about 200 between the two computers (WS and server) on different LANs.
I also tried to uninstall Open-VM-Tools (build-313025), and the package disappears but not the problem. Tried to install Open-VM-Tools-8.8.1 RC 528969 with no better result.

My guess is that there is a problem in Open-VM-Tools, and since I can't remove it once it's installed, I'll have to reinstall the server, and not add VM-tools.

Someone told me to install freebsd vmware tools, that comes with ESXi. The problem there is that it requires Perl, so I installed Perl.
Then it needs some librarys I can't get a hold of. right now I'm stuck on "".
Is it really supposed to be this hard to run a pfSense-installation in VMware?


Actions #1

Updated by Robin Friberg almost 10 years ago

Forgot to specify some stuff:

I got two installations, one in prod and one in test.
The one in test was the one i tried without ever having installed Open-VM-Tools, to transfer data between two computers on different LANs.
When I installed Open-VM-Tools, rebooted, and tried the same test again. I got 13 Mbit (30 with device polling).

My test environment:
WAN - E1000
LAN1 - E1000
LAN2 - E1000

My prod environment:
WAN1 - E1000
WAN2 - E1000
LAN1 - E1000
LAN2 - E1000
LAN3 - E1000
LAN4 - E1000
LAN5 - E1000

That is, no VLAN for pfsense to be aware about. Just plain network cards assigned in VMware.
If there is any other information you might need, please don't hesitate to ask. Since this is running in our production environment, we are in great need of a solution, preferably without having to reinstall the pfSense-box since it's alot of configuration we'll have to redo.


Actions #2

Updated by Chris Buechler almost 10 years ago

  • Status changed from New to Rejected

not a general problem

Actions #3

Updated by Robin Friberg almost 10 years ago

So you'll reject that this is a bug?
I can recreate this problem 100% of the time.
I'll say its a problem that anyone will have, using the versions of VMware and pfSense that I'm using.

VMware build 768111

Does this mean you will not look into the problem?

Actions #4

Updated by Chris Buechler almost 10 years ago

it's not a general problem, this very site runs behind a firewall in the latest version of ESX and it can push 1 Gbps without maxing out a single vCPU. If it were a problem for everyone we would do something about it. Why your specific scenario is the case I don't know but since it's not a general problem, it isn't appropriate here. It's a support request at this point, which means please post to the forum or list.

Actions #5

Updated by Robin Friberg almost 10 years ago

I see, but these people seem to have the same problem:

Actions #6

Updated by Peter Baumann almost 10 years ago

Hi Robin,
You opened the bug for ESXi 5.0 and above you're talking about VMware build 768111 which seems to be VMWare Workstation.
Since about half a year I have pfSense 2.0 and 2.1 versions running successful on ESXi 5.0 with the E1000 drivers.
What is important is that the Host you're using got good hardware specially the Ethernet Cards. I always use the Intel Cards.
At the moment I'm using a Dell R210-II and a SuperMicro Server without one single problem with pfSense virtualized on ESXI 5.0.
So what is your environment? Do you really use ESXI 5.0 or is it VMWare Workstation?

Maybe there's a problem with VMWare Workstation, I never tried to use pfSense 2.x in this environment...



Also available in: Atom PDF