Project

General

Profile

Actions

Bug #2794

closed

PHP Error on NTP

Added by Phil Lavin almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
02/05/2013
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:
All

Description

Fatal error: Cannot use string offset as an array in /usr/local/www/services_ntpd.php on line 43

Caused by $config['installedpackages']['openntpd'] being an empty string.

Fix is to change line 43 to this:

if ($config['installedpackages']['openntpd'] && empty($config['installedpackages']['openntpd']['config'][0]['interface'])) {

Reproduced on yesterday's 2.1 snapshot.

Actions #1

Updated by Jim Pingle almost 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #2

Updated by Jim Pingle almost 9 years ago

Actions #3

Updated by Renato Botelho almost 9 years ago

  • Target version set to 2.1
Actions #4

Updated by Phil Lavin almost 9 years ago

This is resolved - tested in last night's snapshot.

Actions #5

Updated by Jim Pingle almost 9 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF