Project

General

Profile

Actions

Bug #2822

closed

Direction wrong in traffic graph (lan)

Added by Danny Bogaards almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
02/17/2013
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:
All

Description

On my LAN graph I see outgoing traffic (downloads) graphed ok (out), but listed under Bandwidth IN

2.0.2-RELEASE (i386)
FreeBSD 8.1-RELEASE-p13
Alix 2d3


Files

pfsense.png (39.1 KB) pfsense.png Danny Bogaards, 02/17/2013 06:30 AM
Actions #1

Updated by Renato Botelho almost 9 years ago

  • Affected Version set to All
  • Affected Architecture All added
  • Affected Architecture deleted ()

After investigation, i figured out the root cause of this issue. For LAN interface:

- pfSense_get_interface_stats() is used for plot the graph and it considers the traffic as OUT.
- /usr/local/bin/rate is used to build the table with Host IP information, and it considers the traffic as IN.

Actions #2

Updated by Renato Botelho almost 9 years ago

  • Target version set to 2.1
Actions #3

Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

Patch pushed test with new snapshots.

Actions #4

Updated by Ermal Luçi almost 9 years ago

  • % Done changed from 0 to 100

Applied in changeset pfsense-tools:commit:d09e8fddd50e95f731f7cef8d1db92ba1b4f2398.

Actions #5

Updated by Phillip Davis over 8 years ago

Forum thread http://forum.pfsense.org/index.php/topic,59714.0.html
Now the bandwidth by IP display shows separate entries for the source and destination IPs with each IP showing its In and Out figures. (i.e. every byte count appears in 2 entries - 1 for the local IP, and 1 for the remote IP - e.g. when downloading and displaying for LAN, In from the remote internet site IP is high, and out to the local LAN IP is high. That is good/correct!)
It would be good to have an option to display only the "local" IPs or only the "remote" IPs.

Actions #6

Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

After Phil's last submission everything here looks good. thanks!

Actions

Also available in: Atom PDF