Project

General

Profile

Actions

Bug #2838

closed

nanobsd on alix wont boot if usb flash drive attached at boot, stuck on external config loader

Added by Bipin Chandra almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/25/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

i have a lexar 8GB USB flash drive, i created one partition and formatted with "newfs -U /dev/da0s1". now when i reboot the box, it always gets stuck on external config loader for ever and doesnt go ahead until the drive is removed

Actions #1

Updated by Renato Botelho almost 9 years ago

  • Assignee set to Renato Botelho

Could you please edit /etc/ecl.php, change the line 37 from:

$debug = false;

to:

$debug = true;

Then reboot and post the output here.

Actions #2

Updated by Renato Botelho almost 9 years ago

  • Status changed from New to Feedback
Actions #3

Updated by Bipin Chandra almost 9 years ago

i get this when debug is true

External config loader 1.0 is now starting... da0s1
/sbin/mount -t msdosfs /dev/da0s1 /tmp/mnt/cf 2>/dev/null

and it doesnt continue untill i remove usb disk after which i get the below and then it continues

ugen1.2: <Kingston> at usbus1 (disconnected)
umass0: at uhub1, port 1, addr 2 (disconnected)
(da0:umass-sim0:0:0:0): lost device - 1 outstanding, 1 refs
(da0:umass-sim0:0:0:0): Invalidating pack
(da0:umass-sim0:0:0:0): removing device entry

/sbin/mount /dev/da0s1 /tmp/mnt/cf 2>/dev/null

mounted: 0 ad0s3
/sbin/mount -t msdosfs /dev/ad0s3 /tmp/mnt/cf 2>/dev/null

/sbin/mount /dev/ad0s3 /tmp/mnt/cf 2>/dev/null

mounted: 0

Actions #4

Updated by Bipin Chandra almost 9 years ago

while ur at this i noticed one more bug not related to this which prevents a system reboot

Warning: Invalid argument supplied for foreach() in /etc/inc/system.inc on line 1352
Stopping package Cron...done.
Stopping package Shellcmd...done.

Actions #5

Updated by Renato Botelho almost 9 years ago

What happens if, after boot is finished, you plug the flash drive and run:

# /sbin/mount -t msdosfs /dev/da0s1 /tmp/mnt/cf

It seems to be the point where it's freezing.

I couldn't reproduce this issue here, tried with different sizes of flash drive, with msdosfs and ufs.

Actions #6

Updated by Bipin Chandra almost 9 years ago

after boot is finished, i plugged in the usb and went into shell and typed the command and this is what i get

[2.1-BETA1][]/root(1): /sbin/mount -t msdosfs /dev/da0s1 /tm
p/mnt/cf
mount_msdosfs: /dev/da0s1: No such file or directory

bytheway i followed the guide on the below link, first removed all partitions on the usb disk, then created a primary partition and didnt format it and used the newfs -U /dev/da0s1 command on the alix itself to format
http://forum.pfsense.org/index.php/topic,34116.0/prev_next,next.html

Actions #7

Updated by Renato Botelho almost 9 years ago

  • Status changed from Feedback to New
  • Assignee deleted (Renato Botelho)

Couldn't reproduce it on VMs and I don't have an alix board available for testing at this moment

Actions #8

Updated by Bipin Chandra almost 9 years ago

do u want access to mine right now?

Actions #9

Updated by Jim Pingle almost 9 years ago

  • Status changed from New to Closed

This really belongs on a forum thread, not the ticket system, until a bug is actually confirmed.
I can't reproduce it here either on my ALIX with a USB drive attached.

dd if=/dev/zero of=/dev/da0 bs=1M count=1
gpart create -s mbr da0
gpart add -t freebsd da0
newfs -U /dev/da0s1
mount /dev/da0s1 /mnt
df -h /mnt
Filesystem    Size    Used   Avail Capacity  Mounted on
/dev/da0s1    1.8G    4.0k    1.7G     0%    /mnt
/etc/rc.reboot

- Reboots fine, no problems.
Actions #10

Updated by Bipin Chandra almost 9 years ago

can u tell me how did u format the drive?
is this command fine?
newfs -U /dev/da0s1

Actions #11

Updated by Jim Pingle almost 9 years ago

Yes, I put all of the commands I used in my ticket update when I closed it. And please, move this to a forum thread, don't reply on this ticket.

Actions #12

Updated by Bipin Chandra almost 9 years ago

i get this when i run the first command

[2.1-BETA1][]/root(8): dd if=/dev/zero of=/dev/da0 bs=1M cou
nt=1
dd: /dev/da0: Operation not supported

Actions

Also available in: Atom PDF