Project

General

Profile

Feature #2859

Allow to configure different mac addresses for multiple VLANs on same physical interface

Added by Bipin Chandra over 6 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
03/05/2013
Due date:
% Done:

0%

Estimated time:

Description

i have a pppoe connection and my isp requires to spoof a fixed mac but it doesnt seem to work when using vlans, without vlans was fixed some time ago. im using the latest full install x86

History

#1 Updated by Renato Botelho over 6 years ago

  • Status changed from New to Feedback

VLANs follow the same mac address of parent interface. If it's possible, spoof the mac on parent interface to check if it works.

#2 Updated by Bipin Chandra over 6 years ago

how to do that coz i have just one nic and 4 VLANS configured on it, 2 WAN and 2 LAN

#3 Updated by Renato Botelho over 6 years ago

Are just VLANs assigned to interfaces (WAN, LAN, OPTx) or the parent nic is also assigned to any interface?

#4 Updated by Bipin Chandra over 6 years ago

Just 4 vlans, 2 wan and 2 lan

#5 Updated by Renato Botelho over 6 years ago

  • Category set to Interfaces
  • Status changed from Feedback to New

#6 Updated by Renato Botelho over 6 years ago

  • Status changed from New to Feedback
  • Assignee set to Renato Botelho

Did you spoof different mac addresses on VLANs? Is it possible to share <interfaces> section of config.xml?

#7 Updated by Bipin Chandra over 6 years ago

first i create new vlans, like 10.20 etc for the parent single mac id, then assign wan interface to one of them like vlan20, then i goto wan interface and set as pppoe and in the MAC address field i put the spoofed mac id which i want and then connect my pppoe but isp still the original physical nics mac id.

i was reading in the forum etc on this and it was mentioned that the main physical interface needs to be in promiscuous mode but if i do that then wouldnt it affect network performance?

im using multi wan but on same isp which needs my mac id but when both the wans are connected, the isp see the main actual mac id, i want to be able to spoof mac id on one of the connections so for wan1 they see the actual nics mac id which is by default and then on wan2 the spoofed mac id but the pfsense box has one nic so i need to use vlans only

#8 Updated by Bipin Chandra over 6 years ago

and also sometime back i saw some patches which make all vlans use the parent nic mac id only so if the parent nic mac id was changed then all vlans would use that rather than use the parent mac id by default for all vlans except on the one it was spoofed with a different one

#9 Updated by Renato Botelho over 6 years ago

All VLANs will have the same mac address set, you cannot have 2 VLANs (on the same physical interface) with different mac address.

#10 Updated by Bipin Chandra over 6 years ago

but based on this thread, there r a few ppl using it but with promiscuous mode on and i did the same and isp authorizes fine and downlaod speeds are fine, upload seems weak but im still tracing that if its something with isp or something in pfsense

http://forum.pfsense.org/index.php?topic=42726.0;prev_next=prev

#11 Updated by Renato Botelho over 6 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from mac spoof on wan (pppoe) using vlan doesnt spoof to Allow to configure different mac addresses for multiple VLANs on same physical interface
  • Status changed from Feedback to New
  • Assignee deleted (Renato Botelho)
  • Target version changed from 2.1 to Future

Moving it to a feature request and set more appropriate Subject

#12 Updated by Bipin Chandra over 6 years ago

practically is this even possible?

feature request would push it forward for a few months to over an year now, probably if there was an answer to it being possible then i would try and get funds to have this feature done sooner

#13 Updated by Bipin Chandra over 6 years ago

there could be 2 ways to do this

register multiple mac ids using network drivers
or
bridge the interface and then change mac id on the bridge

#14 Updated by Renato Botelho over 6 years ago

Bipin Chandra wrote:

practically is this even possible?

feature request would push it forward for a few months to over an year now, probably if there was an answer to it being possible then i would try and get funds to have this feature done sooner

Yes, it's something possible to do, but requires work on GUI and backend to properly enable promiscuous mode on interface and let user know it's happening. There are 2 ways to get it done faster, make the change yourself and send us a pull request at github or funding the development. I estimate it'll take about 10 hours of work to setup a test environment, develop and test the solution.

#15 Updated by Bipin Chandra over 6 years ago

and total cost of solution would be because when i tried promiscuous mode, my download got faster bu upload was still slow and i had it checked with the isp and there was still some parent mac id fragments causing this so basically promiscuous mode itself doesnt solve it and needs more backend work as well

#16 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Duplicate
  • Target version deleted (Future)

duplicate of #1337

Also available in: Atom PDF