Project

General

Profile

Actions

Bug #2962

closed

IP Aliases cannot be used for routes/gateways

Added by allen landsidel over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
Routing
Target version:
Start date:
04/22/2013
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

Version: 2.0.3-PRERELEASE, 2.1-BETA1 (Apr 18 2013).

Short: The system will not allow a gateway to be created where the IP is within a subnet used by an IP alias -- only the main/primary IP subnet of an interface can be used.

Example:
Two pfsense firewalls. FWA and FWB. Three IPv4 subnets. 192.168.0.0/24, 192.168.1.0/24, 192.168.2.0/24. Assigned as:
FWA: 192.168.0.1 (LAN), 192.168.2.1 (LAN IP Alias)
FWB: 192.168.1.1 (LAN), 192.168.2.2 (LAN IP Alias)

Attempting to define a gateway of 192.168.2.2 in "System -> Routing -> Gateways" on FWA fails with the message that 192.168.2.2 is not within the LAN interface subnet, 192.168.0.1.

Expected Behavior:
Should "just work" with no error message. Works as expected on all normal routing hardware, as well as on standard *BSD installations via "route add ..."

Actions #1

Updated by Renato Botelho over 8 years ago

  • Assignee set to Renato Botelho
  • Target version set to 2.1
Actions #2

Updated by Renato Botelho over 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #3

Updated by allen landsidel over 8 years ago

Thanks. Will test as soon as it makes it into a snapshot build. Didn't seem to be in the latest one.

Actions #4

Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

fixed

Actions #5

Updated by Christian McDonald over 8 years ago

Was the expected result of this revision to prevent the deletion of Virtual IPs that also exist in the same subnet as one of the gateways? Why? I am working on reconfiguring one of my boxes and I would like to delete a virtual IP that is in the /29 subnet of my WAN IPs. I am making some minor topography changes to my infrastructure and would like to delete this virtual IP. I am getting this message "This entry cannot be deleted because it is still referenced by at least one Gateway." This message was part of this revision. However, I have been able to perform this procedure without issue in previous versions.

Actions

Also available in: Atom PDF