Project

General

Profile

Actions

Bug #2995

closed

Unsetting the pfsync synchronize IP doesn't properly set it back to directed multicast

Added by Per von Zweigbergk over 8 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Category:
CARP
Target version:
-
Start date:
05/16/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0.x
Affected Architecture:

Description

Expected: Leaving the "pfsync Synchronize Peer IP" box empty should set up pfsync to use directed multicast.

Actual: If clearing the "pfsync Synchronize Peer IP" setting after it had been set already, it will still use the old value until a reboot.

Workaround 1: Manually enter 224.0.0.240 into the "pfsync Synchronize Peer IP" to enable directed multicast.
Workaround 2: Execute the command "ifconfig pfsync0 -syncpeer".
Workaround 3: Reboot and let the startup scripts configure it correctly.

Affected versions: I have only tested this on 2.0.3.

Patch:

--- /etc/inc/interfaces.inc.orig 2013-05-16 13:47:13.000000000 0200
++ /etc/inc/interfaces.inc 2013-05-16 13:48:02.000000000 0200
@ -1666,7 +1666,7 @
if (is_ipaddr($pfsyncpeerip))
mwexec("/sbin/ifconfig pfsync0 syncdev {$carp_sync_int} syncpeer {$pfsyncpeerip} up", false);
else
- mwexec("/sbin/ifconfig pfsync0 syncdev {$carp_sync_int} up", false);
mwexec("/sbin/ifconfig pfsync0 syncdev {$carp_sync_int} -syncpeer up", false);

sleep(1);

Files

pfsync-syncpeer-patch.txt (654 Bytes) pfsync-syncpeer-patch.txt Per von Zweigbergk, 05/16/2013 06:47 AM
Actions #1

Updated by Per von Zweigbergk over 8 years ago

Seems that the bug report system mangled my patch. Attaching it as a file instead.

Actions #2

Updated by Phillip Davis over 8 years ago

It is much easier for the devs if you use GitHub to submit a change. Then they can directly review and (hopefully) accept it. I use this method for submitting small changes: http://forum.pfsense.org/index.php/topic,47676.0.html

Actions #3

Updated by Renato Botelho over 8 years ago

  • Category set to CARP
  • Status changed from New to Rejected
  • Assignee set to Renato Botelho

It's a duplicate of #2491 and it was already fixed on 2.1. I pushed the fix for RELENG_2_0 today.

Actions

Also available in: Atom PDF