Project

General

Profile

Bug #3056

Unbound not getting IPv6 host overrides

Added by Peter Linss over 7 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DNS Server
Target version:
-
Start date:
06/24/2013
Due date:
% Done:

100%

Estimated time:
Affected Version:
Affected Architecture:
i386

Description

Running latest 2.1RC with unbound 1.4.20_7 installed.

When setting host overrides in Services > DNS Forwarder the overrides are added to unbound.conf properly as local-data, but only for IPv4 addresses. All IPv6 host overrides are ignored.

As a side note, after modifying host overrides (or DHCP reservations), it's necessary to go to Services > Unbound DNS and click Save to regenerate the unbound.conf file. Ideally, when saving the DNS forwarder (or DHCP reservation) it should automatically regenerate the unbound.conf file if unbound is installed and activated (or better, move the host overrides UI to the Unbound DNS config page and disable those on DNS Forwarder).

History

#1 Updated by Peter Linss over 7 years ago

DHCPv6 reservations don't appear to be added to unbound.conf either (DHCPv4 reservations are added).

#2 Updated by Chris Buechler over 7 years ago

  • Target version deleted (2.1)
  • Affected Version deleted (2.1)

#3 Updated by Peter Linss over 7 years ago

Submitted PR #456 as fix.

Turns out the issue isn't IPv6 addresses, it was the duplicate host handling, if both IPv4 and IPv6 addresses were specified for the same, the first one found won.

My fix tracks added host names by IPv4 and IPv6 independently. I also fixed a few other issues: duplicate host names in different domains were ignored; not detecting duplicates between host overrides and DHCP leases/reservations; possible duplicate TXT records; and I also added support for host aliases (both IPv4 and IPv6).

It still needs support for adding DHCPv6 leases and reservations...

#4 Updated by Peter Linss over 7 years ago

Added support for DHCPv6 reservations and /etc/hosts entries in PR 466

#5 Updated by David Wood about 7 years ago

IPv6 host overrides do not work in unbound 1.4.20_8 due to a typo in line 852 of /usr/local/pkg/unbound.inc, which should read:

if (!$added_item_v6[$current_host]) {

The incorrect version has 'curent_host'.

#6 Updated by Warren Baker about 7 years ago

  • Status changed from New to Feedback

#7 Updated by David Wood about 7 years ago

At this moment, with the last commit being 4dfc14961006b0702d1c5e18190b3fcd64dd4d76 , the typo I mentioned is in line 858: https://github.com/pfsense/pfsense-packages/blob/master/config/unbound/unbound.inc#L858

'curent' only appears once in this file, and it's that line that needs changing to 'current' to fix the problem on my machine.

#8 Updated by Warren Baker about 7 years ago

  • % Done changed from 0 to 100

Applied in changeset commit:ec6f62c13304169f44ee47d21a09373cf6f4fd22.

#9 Updated by Warren Baker about 7 years ago

David Wood wrote:

At this moment, with the last commit being 4dfc14961006b0702d1c5e18190b3fcd64dd4d76 , the typo I mentioned is in line 858: https://github.com/pfsense/pfsense-packages/blob/master/config/unbound/unbound.inc#L858

'curent' only appears once in this file, and it's that line that needs changing to 'current' to fix the problem on my machine.

Fixed in latest commit and version has been bumped.

#10 Updated by Chris Buechler about 6 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF