Project

General

Profile

Actions

Bug #3066

closed

Proxy ARP failing with kernel error

Added by Jesse Peterson almost 9 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
07/02/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0.x
Affected Architecture:

Description

Hello, having trouble using Virtual IPs. My problem was worked around by using an Interface alias.

It appeared I was running into this way old issue pertaining to FreeBSD 8-STABLE: http://lists.freebsd.org/pipermail/freebsd-net/2010-February/024462.html
What I could gather from that thread is that in the past there was some issue with creating Proxy ARP entries that do not have an IP in the routing table. Thus they can't be created. But that seems odd that

Basically had a Virtual IP - Proxy ARP configured when the UI acted like everything was configured, but when it was time to save settings and apply the Proxy ARP (presumably using the arp command) there would be these in the system log:

kernel: lla_rt_output: RTM_ADD publish (proxy only) is invalid

If I manually tried to use the arp command to create the arp entry (as a test) I would get the same entries in the kernel. As above I worked around by using an interface alias - but would like to use Proxy ARP instead. Presumably this would hamper VPN connections, too.

This if pfSense 2.0.3 box booting from a USB stick on a Supermicro SYS-5015A-EHF (w/ 2x Intel 82574L gigabit).

Actions

Also available in: Atom PDF