Project

General

Profile

Bug #3205

Partial system freeze when disconnecting USB 3G stick

Added by Louis-David Perron over 6 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
PPP Interfaces
Target version:
-
Start date:
09/16/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1
Affected Architecture:

Description

When we disconnect a live USB 3G stick, parts of the pfSense system freezes, for example, opening the dashboard, showing the interface status page, running "usbconfig", etc.

The dev node cuaU0.3 is still appearing on the filesystem. Replugging the 3G stick won't help.

To unfreeze the system, the workaround is quite simple: kill the php process running 3gstats.php. Only after that the kernel finishes cleaning up the device nodes, etc.

History

#1 Updated by Michal Sawa over 6 years ago

Same here. Huawei E1820. 2.1 RELEASE on physical VIA EPIA and VirtualBox.
First time configured without problems, then I found that:
- pfsense reboot hangs at:
u3g0: at uhub1, port1, addr 2 (disconnected)

- startup hangs at device init. To boot I have to disable interface before reboot or remove it from usb port.

To run connection / unlock pf I tried this method:
- start two separate ssh consoles
- enable interface in "Interfaces"
- disconnect from Status > interfaces
one one of the consoles:
usbconfig d ugen1.2.0 reset
which will be stucked until I kill php (pkill php) from second console. That unlocks usbconfig and web interface.
connect from Status -> interfaces

Sometimes it's works sometimes not and both consoles might be inoperable. Same with connection...
Device tested on Fortigate 100A, laptop with Win7, desktop with XP and desktop with Gentoo without problems so I assume that it's pretty stable.
I know that there was Bug #2433 very similar to mine.

#2 Updated by Bipin Chandra about 6 years ago

i got the same situation as well as with the 3g stick connected if i reboot pfsense then it would just get stuck when on usb4 disconencting and wouldnt let it reboot unless the 3g dongle is unplugged

#3 Updated by Bipin Chandra about 6 years ago

getting stuck on reboot with active 3g dongle is getting a serious issue for me, i have tried 3 different 3g dongles from d-link, nokia, huwaei and when in modem mode and if u reboot then system hangs but when in storage mode and u reboot then it reboots just fine

#4 Updated by Bipin Chandra over 5 years ago

any fix for this as its still troubling me

#5 Updated by Chris Buechler almost 5 years ago

I suspect this is probably fixed in 2.2x versions because of FreeBSD 10.1 base. Anyone who was seeing this able to confirm or deny the same issue on 2.2x?

#6 Updated by Bipin Chandra almost 5 years ago

ys seems fixed

#7 Updated by Chris Buechler almost 5 years ago

  • Status changed from New to Resolved

thanks for the feedback, Bipin.

Also available in: Atom PDF