Project

General

Profile

Bug #3242

editing alias url table doesnt show full link

Added by Bipin Chandra over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
09/29/2013
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.1
Affected Architecture:

Description

when u add a URL table link under alias, it works fine and when u go under aliases it shows the link also properly such as www.something.com/blocklist.txt but when u go and edit it u see only www.something.com, the remaining path to the actual file disappears

Associated revisions

Revision 4e8a79a8 (diff)
Added by Renato Botelho over 7 years ago

Fix #3242 and some code cleanup:

- Only explode '/' and set address_subnet when address is a subnet, it
fixes issue reported at #3242
- While I'm here, do some cleanup on the way addresses are treated
- Remove unecessary variable $tracker, we already have $counter set
with the same value
- Use if:endif and while:endwhile where there is html block inside the
block
- Use more meaning names for variables instead of item, item2, item3
and item4
- Use while($counter <= $count()) instead of using foreach referencing
array using $counter inside

Revision 2db5f9c2 (diff)
Added by Renato Botelho over 7 years ago

Fix #3242 and some code cleanup:

- Only explode '/' and set address_subnet when address is a subnet, it
fixes issue reported at #3242
- While I'm here, do some cleanup on the way addresses are treated
- Remove unecessary variable $tracker, we already have $counter set
with the same value
- Use if:endif and while:endwhile where there is html block inside the
block
- Use more meaning names for variables instead of item, item2, item3
and item4
- Use while($counter <= $count()) instead of using foreach referencing
array using $counter inside

History

#1 Updated by Renato Botelho over 7 years ago

  • Status changed from New to Feedback

I added and edited URL Table aliases lots of times and couldn't reproduce it. Is it happening all the time? Are you running 2.1-RELEASE?

#2 Updated by Bipin Chandra over 7 years ago

yes i have the 2.1 release in 2 alix boxes and 2 full installs and its same on all, happens all the time

#3 Updated by Bipin Chandra over 7 years ago

its just a GUI bug i guess so can be fixed easily, the bug is in the edit page, it seems to strip the portion after /

#4 Updated by Renato Botelho over 7 years ago

I couldn't replicate the issue on any of my test systems.

#5 Updated by Bipin Chandra over 7 years ago

shall i send u my config file if that may show something?

#6 Updated by Renato Botelho over 7 years ago

Bipin Chandra wrote:

shall i send u my config file if that may show something?

yes please, send it to

#7 Updated by Bipin Chandra over 7 years ago

sent

#8 Updated by Renato Botelho over 7 years ago

I got it, the problem only happens because your URL doesn't have protocol. I pushed a fix.

#9 Updated by Renato Botelho over 7 years ago

  • % Done changed from 0 to 100

#11 Updated by Bipin Chandra over 7 years ago

plz mark this as resolved

#12 Updated by Jim Pingle over 7 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF