Project

General

Profile

Bug #3286

Radvd will not function with IPv6 Prefix delegation other than 64 on WAN

Added by Alex Fox about 6 years ago. Updated about 4 years ago.

Status:
Not a Bug
Priority:
High
Assignee:
-
Category:
DHCP (IPv6)
Target version:
-
Start date:
10/23/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

Radvd functions properly when LAN interface is set as tracking to WAN and WAN is set to DHCP6 with a prefix delegation size is 64. When the prefix delegation size is set to a value such as 62 or 60 radvd is completely missing from the status->services page. Additionally, the only IPv6 address present on the LAN interface is fe80::1:1. Toggling "Send IPv6 prefix hint" (plus saving and applying) has no impact on the absence of radvd. I verified my findings on a clean 2.1 i386 instal with a stock configuration with no changes other than those which pertain to IPv6 on the WAN interface. Restarting the box after changing the prefix delegation to 60 changes nothing. Changing the prefix delegation back to 64 restores radvd and IPv6 connectivity on the LAN interface, even without restarting the box. My ISP is Comcast and /60 delegations are available in my area, verified by a Cisco 1841 router.

vlans_interfaces_P64.xml (1.61 KB) vlans_interfaces_P64.xml Vlans and Interfaces with PD of 64 on WAN Alex Fox, 10/24/2013 03:54 PM
radvd_P64.conf (368 Bytes) radvd_P64.conf Radvd.conf with PD of 64 on WAN Alex Fox, 10/24/2013 03:54 PM
radvd_P60.conf (38 Bytes) radvd_P60.conf Radvd.conf with PD of 60 on WAN Alex Fox, 10/24/2013 03:54 PM
vlans_interfaces_P60.xml (1.61 KB) vlans_interfaces_P60.xml Vlans and Interfaces with PD of 60 on WAN Alex Fox, 10/24/2013 03:54 PM
dhcp6c_wan_P64.conf (365 Bytes) dhcp6c_wan_P64.conf Alex Fox, 10/31/2013 03:09 PM
dhcp6c_wan_P60.conf (364 Bytes) dhcp6c_wan_P60.conf Alex Fox, 10/31/2013 03:09 PM

History

#1 Updated by Alex Fox about 6 years ago

Additional information, if it helps. The LAN and WAN interfaces are as follows:
LAN:em0
WAN:em0_vlan100

#2 Updated by Renato Botelho about 6 years ago

Could you share relevant part of config.xml and radvd.conf?

#3 Updated by Alex Fox about 6 years ago

I am too busy to pull the files from a completely stock setup but I was able to pull them from a clean 2.1 install with my custom (restored) config on it.

#4 Updated by Renato Botelho about 6 years ago

Could you also share dhcp6c conf?

#6 Updated by Ermal Lu├ži over 5 years ago

What would be needed is you system log or at least o confirmation from ifconfig that dhcp6c is retrieving something from upstream servers.

#7 Updated by Michael Virgilio almost 5 years ago

Just wanted to add a comment here... it's possible that this is not a pfSense bug. DHCPv6+PD leases a prefix of the requested size based on the DUID. So if the client requests a /64 prefix first, then it will not be able to get a /60 until the first /64 lease has expired, or if the ISP deletes the lease for that DUID. This is why the user cannot obtain a /60 after a /64 was requested first by the same host (Comcast's default expiration time is one week).

I also have Comcast and had my IPv6 settings set to request a /60 from the start. This not only worked just fine, I've also used the additional subnets without any problems.

A workaround for the issue of waiting for the lease to expire would be to allow changing the DUID, as mentioned in feature 3971, so that the ISP sees a new DUID and can allocate a new prefix of the desired size.

#8 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Feedback

I don't think this is a bug, along the lines of what Michael mentioned in the last comment.

Alex: can you still replicate issues on 2.2.4?

#9 Updated by Chris Buechler about 4 years ago

  • Status changed from Feedback to Not a Bug
  • Affected Version deleted (2.1-IPv6)

has to be along the lines of what Michael described, this definitely works.

Also available in: Atom PDF