Project

General

Profile

Bug #3350

Disabling and enabling VLAN leaves VLAN interface missing

Added by Chris Buechler about 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
12/02/2013
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.1
Affected Architecture:

Description

If you disable an interface that's a VLAN, it deletes the VLAN, and re-enabling that interface doesn't add the VLAN interface back.

For example, to replicate:
Interfaces>assign, VLANs, add a VLAN. Back to assignments tab, assign it as OPT1.
Go to Interfaces>OPT1, enable the interface, put a static IPv4 IP on it, save and apply.
Go back to Interfaces>OPT1 and disable the interface. Note the VLAN interface is deleted at this point.
Re-enable OPT1 and the VLAN interface will still be gone.

When disabling a VLAN interface, it shouldn't ever delete the underlying VLAN interface, it should only remove the IP config from it. VLAN interfaces should only be deleted when they're deleted under Interfaces>assign, VLANs tab.

Associated revisions

Revision 5bc62353 (diff)
Added by Renato Botelho about 6 years ago

Fix #3350. Do not destroy an interface when it's being disabled

Revision f70a140f (diff)
Added by Renato Botelho about 6 years ago

Fix #3350. Do not destroy an interface when it's being disabled

History

#1 Updated by Renato Botelho about 6 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Ermal Luçi almost 6 years ago

It would be better to revert this commit now that interface_cofnigure does the right job at detecting if an interface needs to be created or not!
This breaks the case when the parent of a vlan is changed!

@Renato,

please review the above comments.

#4 Updated by Renato Botelho almost 6 years ago

I reverted it, will leave it as feedback waiting a confirmation from Chris

#5 Updated by Chris Buechler almost 6 years ago

  • Status changed from Feedback to New
  • Target version changed from 2.1.1 to 2.2
  • % Done changed from 100 to 0

#6 Updated by Ermal Luçi over 5 years ago

  • Status changed from New to Feedback

This should be fixed already by me since long now.

#7 Updated by Trond Vindenes over 5 years ago

I can confirm that this is resolved. I followed the procedure given in the description to replicate the issue, the vlan interface isn't being deleted now.

#8 Updated by Renato Botelho over 5 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF