Project

General

Profile

Bug #3720

Captive portal on httpS redirect to a http page

Added by Sander Naudts over 6 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Captive Portal
Target version:
-
Start date:
06/25/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

When you set your captive portal to use httpS and set a after authentication url (redirect) to a http (not S) url, the redirection 'll fail. (https to https works, https to http not)

In Pfsense 2.0 it did work so I suppose this is a bug in 2.1.3.

History

#1 Updated by A FL about 2 years ago

I could not reproduce this using Firefox on Linux. Entering "http://http.badssl.com" in after-authentication URL while using captiveportal on HTTPS works like a charm for me.

Could you have this issue because you forgot to include the scheme (eg, "http://") in the URL ?

- If yes, this issue can be closed (not a bug)
- If no, then this issue can be marked as resolved

#2 Updated by Sander Naudts about 2 years ago

As this was a bug 4 years ago, I think it is fixed now because I also don't have the issue anymore in the latest version.

Can be marked as resolved.

#3 Updated by Renato Botelho about 2 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF