Project

General

Profile

Bug #3789

rc.update_bogons.sh and login shell ignore http proxy settings

Added by Buster de about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
08/01/2014
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Hi,

I need to configure a http proxy for www access.
It seems that /etc/rc.update_bogons.sh ignores proxy settings:

Aug 1 12:38:35 root: rc.update_bogons.sh is sleeping for 56036
Aug 1 12:38:35 root: rc.update_bogons.sh is starting up.
Aug 1 12:38:35 root: Could not extract fullbogons-ipv6.txt
Aug 1 12:38:35 root: Could not download http://files.pfsense.org/lists/fullbogons-ipv6.txt
Aug 1 12:36:17 root: Could not extract fullbogons-ipv4.txt
Aug 1 12:36:17 root: Could not download http://files.pfsense.org/lists/fullbogons-ipv4.txt
Aug 1 12:33:59 root: rc.update_bogons.sh is beginning the update cycle.
Aug 1 12:33:59 root: rc.update_bogons.sh is starting up.

Furthermore local shell login ignores proxy setting too.

[2.1.4-RELEASE][root@firewall]/root(6): env | grep -i proxy

gives empty result and fetch won't work

[2.1.4-RELEASE][root@firewall]/root(9): fetch http://files.pfsense.org/lists/fullbogons-ipv4.txt
fetch: transfer timed out

This one works:

[2.1.4-RELEASE][root@firewall]/root(8): env http_proxy=http://172.28.133.242:3128 /etc/rc.update_bogons.sh now

log from webinterface:

Aug 1 12:55:36 root: rc.update_bogons.sh is ending the update cycle.
Aug 1 12:55:36 root: Bogons V6 file downloaded but not updating IPv6 bogons table because IPv6 Allow is off
Aug 1 12:55:36 root: Bogons V4 file downloaded: 2644 addresses added.
Aug 1 12:55:31 root: rc.update_bogons.sh is beginning the update cycle.
Aug 1 12:55:31 root: rc.update_bogons.sh is starting up.

/etc/rc.firmware_auto might be affected too (I didn't test).

Associated revisions

Revision 664adf38 (diff)
Added by Ermal Luçi almost 4 years ago

Ticket #3789. Put a start at using the proxyurl/proxyport from system configured settings for bogons. It still does not consider the user/pass configured

Revision 992f60d0 (diff)
Added by Renato Botelho almost 4 years ago

Set proxy env vars on interactive shell and also on crontab to make all scripts be able to use it. Ticket #3789

History

#1 Updated by Chris Buechler almost 4 years ago

  • Category set to Operating System
  • Target version set to 2.2

this is really annoying in proxy scenarios and should be trivially easy to fix. Just a matter of setting ftp_proxy, http_proxy and https_proxy environment variables.

#2 Updated by Ermal Luçi almost 4 years ago

  • Status changed from New to Feedback

A patch for proxy support without username/password configured on system->settings will be considered now.

#3 Updated by Chris Buechler almost 4 years ago

why do it there in update_bogons? Set it as an env variable in general and nothing else needs to be touched.

#4 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Confirmed
  • Affected Version changed from 2.1.x to All
  • Affected Documentation 0 added

this needs to be set in tcshrc so it applies to everything using fetch and similar utilities now and in the future.

#5 Updated by Chris Buechler almost 4 years ago

  • Assignee set to Renato Botelho

#6 Updated by Renato Botelho almost 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

Implemented as Chris suggested

#7 Updated by Chris Buechler almost 4 years ago

  • Assignee changed from Renato Botelho to Chris Buechler

to me for testing

#8 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF