Project

General

Profile

Bug #3853

DHCP Server failover_peerip is not synchronized on 2.2 with CARP

Added by Jim Pingle over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DHCP Server
Target version:
Start date:
09/09/2014
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2
Affected Architecture:
All

Description

On 2.1.x and before, the failover_peerip is synchronized and adjusted for use by the secondary. On 2.2 the value is blank on the secondary after sync. The other settings synchronize as expected.

Associated revisions

Revision 572f6ccc (diff)
Added by Jim Pingle over 4 years ago

Fix guess_interface_from_ip() to account for differences in netstat output. Fixes #3853

History

#1 Updated by Jim Pingle over 4 years ago

  • Assignee set to Jim Pingle

#2 Updated by Jim Pingle over 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Trond Vindenes about 4 years ago

Doesn't seem to have been fixed yet: https://forum.pfsense.org/index.php?topic=81948.0

#4 Updated by Jim Pingle about 4 years ago

I upgraded my test VM and tried it again, it still works. If I remove the failover IP, it becomes blank on the secondary. If I add it back in, it adjusts and synchronizes accordingly. You may have a configuration issue, not a bug. The field did synchronize on earlier versions.

You place the IP of the secondary system in the settings on the primary, during the sync, the primary puts its own IP in there and places those settings on the secondary, so they each point to one another.

#5 Updated by Chris Buechler about 4 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF