Project

General

Profile

Actions

Bug #3877

closed

OpenVPN Client Connection routing Internettraffic

Added by Christian Merges almost 7 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
-
Start date:
09/21/2014
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.2
Affected Architecture:
amd64

Description

In 2.1 i have configured a VPN-Provider as a OpenVPN Client Connectionl:
importing certificates, add openvpn clientconnection, store user/pass in separate file, assign an dhcp interface to the openvpnclientconnection, created outbond nat rule, created firewall rule with advanced gateway flag.

Doing this in 2.2 the same way except, that user/pass doesn't needs to be stored in separte file. After adding the firwall rule for the specific IP adresse, wich needs to be online via vpn, ther was no internetconnection on this client.

Testing traceroute from the client only gives me timeouts.
Removing the firewall rule, the client is back online, but without vpn.

Actions #1

Updated by Dmitriy K almost 7 years ago

1. There is no need to set IPv4 Configuration Type to "DHCP" at all. Ovpn client interfaces are autoconfigurable. Set type to "None";
2. As far as I understand, you want to route some traffic from a certain LAN PC via given ovpn client?
3. if so then just add an outbound NAT rule on ovpn interface with LAN subnet as a source network and that's all;

Actions #2

Updated by Chris Buechler almost 7 years ago

  • Status changed from New to Rejected

config issue, not a bug. Please use one of our support resources for assistance. https://pfsense.org/support

Actions #3

Updated by Chris Buechler about 6 years ago

  • Target version deleted (2.2)
Actions

Also available in: Atom PDF