Project

General

Profile

Actions

Bug #3878

closed

OpenVPN Site to Site Connection HMAC Error

Added by Christian Merges almost 7 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
-
Start date:
09/21/2014
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.2
Affected Architecture:
amd64

Description

on the 2.1 i have a site-to-site vpn to an other 2.1 machine. The other one is the Server.
Authentication is shared key.

On 2.2 I configured the tunnel like in the 2.1 except the new field "digest auth". This was set to "nothing".
Having access to both pfsense maschines from the same computer over wan, it was eaysy to copy and past the shared key. So it should be right.

On the Serversite PFsense getting much HMAC Authentication erros. VPN will not connect.

Actions #1

Updated by Jim Pingle almost 7 years ago

  • Status changed from New to Rejected

Please post in the forum for assistance until a bug has been confirmed.

OpenVPN defaults to a digest of SHA1, as does our GUI. By changing that setting it to 'none' you have created a mismatched configuration since 2.1 and before defaulted to 'sha1' when there was no setting in the GUI.

Actions #2

Updated by Chris Buechler about 6 years ago

  • Target version deleted (2.2)
Actions

Also available in: Atom PDF